About Installing Sqlite3, HDBC and convertible

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

About Installing Sqlite3, HDBC and convertible

Eyüp Kaan AKAY
Hi. I want to use sqlite3. When I work to install it, I got this error:
hdbc-sqlite3-master$ ghc --make -o setup Setup.lhs
hdbc-sqlite3-master$ ghc --make -o setup Setup.hs
[1 of 1] Compiling Main ( Setup.hs, Setup.o )
Linking setup ...
hdbc-sqlite3-master$ ./setup configure
Configuring HDBC-sqlite3-2.3.3.1...
setup: At least the following dependencies are missing:
HDBC >=2.3.0.0, utf8-string -any

When I want to install HDBC, I got this error:

HDBC-2.4.0.2$ ghc --make -o setup Setup.lhs
HDBC-2.4.0.2$ ./setup configure
Configuring HDBC-2.4.0.2...
setup: At least the following dependencies are missing:
convertible >=1.1.0.0, utf8-string -any

Then I install convertib le and I got any errors then first I work to install HDBC but I got the same error. So what can I do else?








_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: About Installing Sqlite3, HDBC and convertible

Damien Mattei
i'm new to haskell and i'm assume you're trying to compile all the stuff
"by hand", instead why don't you install cabal and install them using cabal?
i'm trying also to use database with haskell,i use cabal to install HDBC
this way:(from my comments in code)

-- install those modules with cabal:
  /usr/local/bin/cabal update (if needed)
  /usr/local/bin/cabal install HDBC

Damien

Le 05/12/2018 12:15, Eyüp Kaan AKAY a écrit :

> Hi. I want to use sqlite3. When I work to install it, I got this error:
> *hdbc-sqlite3-master$* ghc --make -o setup Setup.lhs
> *hdbc-sqlite3-master$* ghc --make -o setup Setup.hs
> [1 of 1] Compiling Main ( Setup.hs, Setup.o )
> Linking setup ...
> *hdbc-sqlite3-master$* ./setup configure
> Configuring HDBC-sqlite3-2.3.3.1...
> setup: At least the following dependencies are missing:
> HDBC >=2.3.0.0, utf8-string -any
>
> When I want to install HDBC, I got this error:
>
> *HDBC-2.4.0.2$* ghc --make -o setup Setup.lhs
> *HDBC-2.4.0.2$ *./setup configure
> Configuring HDBC-2.4.0.2...
> setup: At least the following dependencies are missing:
> convertible >=1.1.0.0, utf8-string -any
>
> Then I install convertib le and I got any errors then first I work to
> install HDBC but I got the same error. So what can I do else?
>
>
>
>
>
>
>
>
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
>

--
[hidden email], [hidden email], UNS / OCA / CNRS
_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners