Build problems (hsp, trhsx, ultimately Happstack)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
20 messages Options
Reply | Threaded
Open this post in threaded view
|

Build problems (hsp, trhsx, ultimately Happstack)

Alexander Solla-2
Consider the following bash session:

[ ajs@kizaru:~/ ]$ which trhsx
/home/ajs/.cabal/bin/trhsx

[ ajs@kizaru:~/ ]$ trhsx
Usage: trhsx <infile> [<outfile>]

[ ajs@kizaru:~/ ]$ cabal install hsp
Resolving dependencies...
Configuring hsp-0.4.5...
Preprocessing library hsp-0.4.5...
Building hsp-0.4.5...
ghc: could not execute: trhsx
cabal: Error: some packages failed to install:
hsp-0.4.5 failed during the building phase. The exception was:
ExitFailure 1

Does anybody have any suggestions?  I'm trying to install Happstack on  
Arch Linux (GHC 6.12.1).   ~/.cabal/bin/ is in my path and trhsx runs.

I've had this problem before, and I think I ran cabal as root for the  
HSP package.  That's not working this time.  I get the same failure.
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

tphyahoo
I've had this problem too.

I believe trhsx is installed by

http://hackage.haskell.org/package/hsx

So, you might need to
-- upgrade hsx
-- make sure that the upgraded trhsx executable is the one being
executed by cabal install hsx (maybe deleting/temporarily moving other
trhsx exes)

thomas.

2010/4/22 Alexander Solla <[hidden email]>:

> Consider the following bash session:
>
> [ ajs@kizaru:~/ ]$ which trhsx
> /home/ajs/.cabal/bin/trhsx
>
> [ ajs@kizaru:~/ ]$ trhsx
> Usage: trhsx <infile> [<outfile>]
>
> [ ajs@kizaru:~/ ]$ cabal install hsp
> Resolving dependencies...
> Configuring hsp-0.4.5...
> Preprocessing library hsp-0.4.5...
> Building hsp-0.4.5...
> ghc: could not execute: trhsx
> cabal: Error: some packages failed to install:
> hsp-0.4.5 failed during the building phase. The exception was:
> ExitFailure 1
>
> Does anybody have any suggestions?  I'm trying to install Happstack on Arch
> Linux (GHC 6.12.1).   ~/.cabal/bin/ is in my path and trhsx runs.
>
> I've had this problem before, and I think I ran cabal as root for the HSP
> package.  That's not working this time.  I get the same failure.
> _______________________________________________
> Haskell-Cafe mailing list
> [hidden email]
> http://www.haskell.org/mailman/listinfo/haskell-cafe
>
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Alexander Solla-2

On Apr 23, 2010, at 2:59 PM, Thomas Hartman wrote:

> So, you might need to
> -- upgrade hsx
> -- make sure that the upgraded trhsx executable is the one being
> executed by cabal install hsx (maybe deleting/temporarily moving other
> trhsx exes)

Unfortunately, this suggestion didn't work out for me.  I read through  
all the relevant GHC documentation I could find -- I didn't see a way  
to set a specific path for GHC to search through for binaries.  
Whether I moved trhsx or not, the error was the same.  But it's the  
only trhsx on my system.

I've upgraded through every version of hsx that is compatible with  
Happstack, and tried every hsp that is compatible with Happstack.  
I've built Cabal-install, removed it, used the Arch package; tried  
global/user installs for Happstack;  did a darcs get on the official  
Happstack repo, and tried to build using its build script, on a fresh  
GHC install; and other stuff that I guess didn't make much sense.

It always broke in the same place:

[ ajs@kizaru:~/ ]$ cabal install hsp-0.4.5
Resolving dependencies...
Configuring hsp-0.4.5...
Preprocessing library hsp-0.4.5...
Building hsp-0.4.5...
ghc: could not execute: trhsx
cabal: Error: some packages failed to install:
hsp-0.4.5 failed during the building phase. The exception was:
ExitFailure 1

The strange thing about it (that I noticed) is that GHC reports  
failing during the building phase instead of the preprocessing phase.  
Maybe this is just an artifact of the logging system, but it seems  
like GHC is doing something strange.  If I increase the verbosity,  
(near the end) I get:

*** Haskell pre-processor:
trhsx src/HSP/HJScript.hs /tmp/ghc6345_0/ghc6345_6.hscpp /tmp/
ghc6345_0/ghc6345_0.hspp
*** Deleting temp files:
Deleting: /tmp/ghc6345_0/ghc6345_0.hspp /tmp/ghc6345_0/
ghc6345_6.hscpp /tmp/ghc6345_0/ghc6345_5.hscpp /tmp/ghc6345_0/
ghc6345_4.hscpp /tmp/ghc6345_0/ghc6345_3.hscpp /tmp/ghc6345_0/
ghc6345_2.hscpp /tmp/ghc6345_0/ghc6345_1.hscpp /tmp/ghc6345_0/
ghc6345_0.hscpp
Warning: deleting non-existent /tmp/ghc6345_0/ghc6345_0.hspp
*** Deleting temp dirs:
Deleting: /tmp/ghc6345_0
ghc: could not execute: trhsx
/usr/bin/ghc returned ExitFailure 1
cabal: Error: some packages failed to install:
hsp-0.4.5 failed during the building phase. The exception was:
ExitFailure 1


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Jeremy Shaw-3
Hello,

Does trying to install hsp-0.5.1 work any better?

- jeremy

On Apr 26, 2010, at 12:27 PM, Alexander Solla wrote:

>
> On Apr 23, 2010, at 2:59 PM, Thomas Hartman wrote:
>
>> So, you might need to
>> -- upgrade hsx
>> -- make sure that the upgraded trhsx executable is the one being
>> executed by cabal install hsx (maybe deleting/temporarily moving  
>> other
>> trhsx exes)
>
> Unfortunately, this suggestion didn't work out for me.  I read  
> through all the relevant GHC documentation I could find -- I didn't  
> see a way to set a specific path for GHC to search through for  
> binaries.  Whether I moved trhsx or not, the error was the same.  
> But it's the only trhsx on my system.
>
> I've upgraded through every version of hsx that is compatible with  
> Happstack, and tried every hsp that is compatible with Happstack.  
> I've built Cabal-install, removed it, used the Arch package; tried  
> global/user installs for Happstack;  did a darcs get on the official  
> Happstack repo, and tried to build using its build script, on a  
> fresh GHC install; and other stuff that I guess didn't make much  
> sense.
>
> It always broke in the same place:
>
> [ ajs@kizaru:~/ ]$ cabal install hsp-0.4.5
> Resolving dependencies...
> Configuring hsp-0.4.5...
> Preprocessing library hsp-0.4.5...
> Building hsp-0.4.5...
> ghc: could not execute: trhsx
> cabal: Error: some packages failed to install:
> hsp-0.4.5 failed during the building phase. The exception was:
> ExitFailure 1
>
> The strange thing about it (that I noticed) is that GHC reports  
> failing during the building phase instead of the preprocessing  
> phase.  Maybe this is just an artifact of the logging system, but it  
> seems like GHC is doing something strange.  If I increase the  
> verbosity, (near the end) I get:
>
> *** Haskell pre-processor:
> trhsx src/HSP/HJScript.hs /tmp/ghc6345_0/ghc6345_6.hscpp /tmp/
> ghc6345_0/ghc6345_0.hspp
> *** Deleting temp files:
> Deleting: /tmp/ghc6345_0/ghc6345_0.hspp /tmp/ghc6345_0/
> ghc6345_6.hscpp /tmp/ghc6345_0/ghc6345_5.hscpp /tmp/ghc6345_0/
> ghc6345_4.hscpp /tmp/ghc6345_0/ghc6345_3.hscpp /tmp/ghc6345_0/
> ghc6345_2.hscpp /tmp/ghc6345_0/ghc6345_1.hscpp /tmp/ghc6345_0/
> ghc6345_0.hscpp
> Warning: deleting non-existent /tmp/ghc6345_0/ghc6345_0.hspp
> *** Deleting temp dirs:
> Deleting: /tmp/ghc6345_0
> ghc: could not execute: trhsx
> /usr/bin/ghc returned ExitFailure 1
> cabal: Error: some packages failed to install:
> hsp-0.4.5 failed during the building phase. The exception was:
> ExitFailure 1
>
>
> _______________________________________________
> Haskell-Cafe mailing list
> [hidden email]
> http://www.haskell.org/mailman/listinfo/haskell-cafe

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Alexander Solla-2

On Apr 26, 2010, at 12:30 PM, Jeremy Shaw wrote:

>
> Does trying to install hsp-0.5.1 work any better?

I hadn't tried it, since it forces hsx-0.7 to install.  But I gave it  
a shot, and it fails the same way:

[ ajs@kizaru:~/ ]$ cabal install hsp-0.5.1
Resolving dependencies...
Configuring hsp-0.5.1...
Preprocessing library hsp-0.5.1...
Building hsp-0.5.1...
ghc: could not execute: trhsx
cabal: Error: some packages failed to install:
hsp-0.5.1 failed during the building phase. The exception was:
ExitFailure 1

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Gregory Collins-3
Alexander Solla <[hidden email]> writes:

> On Apr 26, 2010, at 12:30 PM, Jeremy Shaw wrote:
>
>>
>> Does trying to install hsp-0.5.1 work any better?
>
> I hadn't tried it, since it forces hsx-0.7 to install.  But I gave it a shot,
> and it fails the same way:
>
> [ ajs@kizaru:~/ ]$ cabal install hsp-0.5.1
> Resolving dependencies...
> Configuring hsp-0.5.1...
> Preprocessing library hsp-0.5.1...
> Building hsp-0.5.1...
> ghc: could not execute: trhsx
> cabal: Error: some packages failed to install:
> hsp-0.5.1 failed during the building phase. The exception was:
> ExitFailure 1

Is "$HOME/.cabal/bin" on your $PATH?

G
--
Gregory Collins <[hidden email]>
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Alexander Solla-2

On Apr 26, 2010, at 1:23 PM, Gregory Collins wrote:

> Is "$HOME/.cabal/bin" on your $PATH?


Argh.

I had "~/.cabal/bin" in my $PATH instead of "$HOME/.cabal/bin".  I'm  
still not sure what the semantic difference is in this use case, but  
one ($HOME) works and the other (~/) doesn't.

Thanks everybody
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Daniel Fischer-4
In reply to this post by Gregory Collins-3
Am Montag 26 April 2010 22:23:42 schrieb Gregory Collins:

> Alexander Solla <[hidden email]> writes:
> > On Apr 26, 2010, at 12:30 PM, Jeremy Shaw wrote:
> >> Does trying to install hsp-0.5.1 work any better?
> >
> > I hadn't tried it, since it forces hsx-0.7 to install.  But I gave it
> > a shot, and it fails the same way:
> >
> > [ ajs@kizaru:~/ ]$ cabal install hsp-0.5.1
> > Resolving dependencies...
> > Configuring hsp-0.5.1...
> > Preprocessing library hsp-0.5.1...
> > Building hsp-0.5.1...
> > ghc: could not execute: trhsx
> > cabal: Error: some packages failed to install:
> > hsp-0.5.1 failed during the building phase. The exception was:
> > ExitFailure 1
>
> Is "$HOME/.cabal/bin" on your $PATH?
>
> G

He said it is. That would've been too easy.
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Warren Harris
In reply to this post by Jeremy Shaw-3
I thought I'd install happstack to give it a try, but immediately hit  
the following build problem:

$ cabal install happstack
Resolving dependencies...
cabal: cannot configure HJScript-0.5.0. It requires hsx >=0.7.0
For the dependency on hsx >=0.7.0 there are these packages: hsx-0.7.0.  
However
none of them are available.
hsx-0.7.0 was excluded because happstack-0.4.1 requires hsx >=0.5.5 &&  
<0.6

Any suggestions? I'm on mac os 10.5.8 with ghc 6.12.1. Thx,

Warren
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Ivan Lazar Miljenovic
Warren Harris <[hidden email]> writes:

> I thought I'd install happstack to give it a try, but immediately hit
> the following build problem:
>
> $ cabal install happstack
> Resolving dependencies...
> cabal: cannot configure HJScript-0.5.0. It requires hsx >=0.7.0
> For the dependency on hsx >=0.7.0 there are these packages:
> hsx-0.7.0. However
> none of them are available.
> hsx-0.7.0 was excluded because happstack-0.4.1 requires hsx >=0.5.5 &&
> <0.6
>
> Any suggestions? I'm on mac os 10.5.8 with ghc 6.12.1. Thx,

Try explicitly building a lower version of HJScript (e.g. 0.4.4) and
then hsp (0.4.5) by hand, and then try building happstack.  This should
get it working (I think).

--
Ivan Lazar Miljenovic
[hidden email]
IvanMiljenovic.wordpress.com
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Alexander Solla-2
In reply to this post by Warren Harris

On Apr 30, 2010, at 11:28 PM, Warren Harris wrote:

> $ cabal install happstack
> Resolving dependencies...
> cabal: cannot configure HJScript-0.5.0. It requires hsx >=0.7.0
> For the dependency on hsx >=0.7.0 there are these packages:  
> hsx-0.7.0. However
> none of them are available.
> hsx-0.7.0 was excluded because happstack-0.4.1 requires hsx >=0.5.5  
> && <0.6


I think that if you run this, you will satisfy all the dependencies:

cabal install "hjscript<0.5.0" happstack


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Warren Harris

On May 1, 2010, at 12:08 AM, Alexander Solla wrote:

I think that if you run this, you will satisfy all the dependencies:

cabal install "hjscript<0.5.0" happstack


Thank you. That worked. I had a similar problem installing the happstack-tutorial, but found that I could work around it with this:

  cabal install "Crypto<4.2.1"

Warren

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Ivan Lazar Miljenovic
Warren Harris <[hidden email]> writes:

> On May 1, 2010, at 12:08 AM, Alexander Solla wrote:
>>
>> I think that if you run this, you will satisfy all the dependencies:
>>
>> cabal install "hjscript<0.5.0" happstack
>>
>
> Thank you. That worked. I had a similar problem installing the
> happstack-tutorial, but found that I could work around it with this:
>
>   cabal install "Crypto<4.2.1"

And this, people, is why bounded dependencies in cabal files are so
desirable.

--
Ivan Lazar Miljenovic
[hidden email]
IvanMiljenovic.wordpress.com
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Warren Harris

On May 1, 2010, at 1:28 AM, Ivan Lazar Miljenovic wrote:

> Warren Harris <[hidden email]> writes:
>
>> On May 1, 2010, at 12:08 AM, Alexander Solla wrote:
>>>
>>> I think that if you run this, you will satisfy all the dependencies:
>>>
>>> cabal install "hjscript<0.5.0" happstack
>>>
>>
>> Thank you. That worked. I had a similar problem installing the
>> happstack-tutorial, but found that I could work around it with this:
>>
>>  cabal install "Crypto<4.2.1"
>
> And this, people, is why bounded dependencies in cabal files are so
> desirable.

Uh... actually I was a little too quick in sending my last message. I  
only built crypto, not the tutorial. Trying again I hit this:

$ cabal install "Crypto<4.2.1" happs-tutorial
Resolving dependencies...
Configuring containers-0.2.0.1...
Preprocessing library containers-0.2.0.1...
Building containers-0.2.0.1...

Data/IntMap.hs:182:7:
     Could not find module `Data.Data':
       It is a member of the hidden package `base'.
       Perhaps you need to add `base' to the build-depends in  
your .cabal file.
       Use -v to see a list of the files searched for.
cabal: Error: some packages failed to install:
HSH-2.0.3 depends on containers-0.2.0.1 which failed to install.
HStringTemplate-0.5 depends on containers-0.2.0.1 which failed to  
install.
HStringTemplateHelpers-0.0.14 depends on containers-0.2.0.1 which  
failed to
install.
HaXml-1.13.3 depends on containers-0.2.0.1 which failed to install.
MissingH-1.0.3 depends on containers-0.2.0.1 which failed to install.
PBKDF2-0.3 depends on containers-0.2.0.1 which failed to install.
SMTPClient-1.0.2 depends on containers-0.2.0.1 which failed to install.
binary-0.5.0.2 depends on containers-0.2.0.1 which failed to install.
containers-0.2.0.1 failed during the building phase. The exception was:
ExitFailure 1
deepseq-1.1.0.0 depends on containers-0.2.0.1 which failed to install.
happs-tutorial-0.9.3 depends on containers-0.2.0.1 which failed to  
install.
happstack-0.4.1 depends on containers-0.2.0.1 which failed to install.
happstack-data-0.4.1 depends on containers-0.2.0.1 which failed to  
install.
happstack-helpers-0.49 depends on containers-0.2.0.1 which failed to  
install.
happstack-ixset-0.4.1 depends on containers-0.2.0.1 which failed to  
install.
happstack-server-0.4.1 depends on containers-0.2.0.1 which failed to  
install.
happstack-state-0.4.1 depends on containers-0.2.0.1 which failed to  
install.
happstack-util-0.4.1 depends on containers-0.2.0.1 which failed to  
install.
hslogger-1.0.10 depends on containers-0.2.0.1 which failed to install.
parallel-2.2.0.1 depends on containers-0.2.0.1 which failed to install.
pureMD5-1.0.0.3 depends on containers-0.2.0.1 which failed to install.
regex-base-0.93.1 depends on containers-0.2.0.1 which failed to install.
regex-compat-0.92 depends on containers-0.2.0.1 which failed to install.
regex-posix-0.94.1 depends on containers-0.2.0.1 which failed to  
install.
strict-concurrency-0.2.3 depends on containers-0.2.0.1 which failed to
install.
syb-with-class-0.6.1 depends on containers-0.2.0.1 which failed to  
install.
template-haskell-2.4.0.0 depends on containers-0.2.0.1 which failed to
install.

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Daniel Fischer-4
Am Samstag 01 Mai 2010 10:34:22 schrieb Warren Harris:

> On May 1, 2010, at 1:28 AM, Ivan Lazar Miljenovic wrote:
> > Warren Harris <[hidden email]> writes:
> >> On May 1, 2010, at 12:08 AM, Alexander Solla wrote:
> >>> I think that if you run this, you will satisfy all the dependencies:
> >>>
> >>> cabal install "hjscript<0.5.0" happstack
> >>
> >> Thank you. That worked. I had a similar problem installing the
> >> happstack-tutorial, but found that I could work around it with this:
> >>
> >>  cabal install "Crypto<4.2.1"
> >
> > And this, people, is why bounded dependencies in cabal files are so
> > desirable.

More than desirable.

>
> Uh... actually I was a little too quick in sending my last message. I
> only built crypto, not the tutorial. Trying again I hit this:
>
> $ cabal install "Crypto<4.2.1" happs-tutorial

Try

$ cabal install  --constraint="Crypto<4.2.1" --constraint="HJScript<0.5"
happs-tutorial

(use --dry-run first to see if it finds immediate problems and if it does,
add more constraints until it works, the above combination gave

In order, the following would be installed (use -v for more details):                                                              
DebugTraceHelpers-0.12
<snip lots of packages>

for me).


> Resolving dependencies...
> Configuring containers-0.2.0.1...
> Preprocessing library containers-0.2.0.1...
> Building containers-0.2.0.1...
>
> Data/IntMap.hs:182:7:
>      Could not find module `Data.Data':
>        It is a member of the hidden package `base'.
>        Perhaps you need to add `base' to the build-depends in
> your .cabal file.
>        Use -v to see a list of the files searched for.
> cabal: Error: some packages failed to install:
> HSH-2.0.3 depends on containers-0.2.0.1 which failed to install.
> HStringTemplate-0.5 depends on containers-0.2.0.1 which failed to
> install.
> HStringTemplateHelpers-0.0.14 depends on containers-0.2.0.1 which
> failed to
> install.
> HaXml-1.13.3 depends on containers-0.2.0.1 which failed to install.
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Jeremy Shaw-3
In reply to this post by Warren Harris
Hello,

I would recommend:

cd happstack
chmod +x bin/build-install-all.sh
./bin/build-install-all.sh

This should install the latest version of happstack from darcs which resolves most install problems. I intend to release it any minute now, but I am waiting for a patch to hsp.cabal to be applied.

- jeremy

On May 1, 2010, at 1:28 AM, Warren Harris wrote:

I thought I'd install happstack to give it a try, but immediately hit the following build problem:

$ cabal install happstack
Resolving dependencies...
cabal: cannot configure HJScript-0.5.0. It requires hsx >=0.7.0
For the dependency on hsx >=0.7.0 there are these packages: hsx-0.7.0. However
none of them are available.
hsx-0.7.0 was excluded because happstack-0.4.1 requires hsx >=0.5.5 && <0.6

Any suggestions? I'm on mac os 10.5.8 with ghc 6.12.1. Thx,

Warren


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Warren Harris
In reply to this post by Daniel Fischer-4

On May 1, 2010, at 3:39 AM, Daniel Fischer wrote:

Try

$ cabal install  --constraint="Crypto<4.2.1" --constraint="HJScript<0.5" 
happs-tutorial 

This had the same problem building containers:

Building containers-0.2.0.1...

Data/IntMap.hs:182:7:
    Could not find module `Data.Data':
      It is a member of the hidden package `base'.
      Perhaps you need to add `base' to the build-depends in your .cabal file.
      Use -v to see a list of the files searched for.
cabal: Error: some packages failed to install:


On May 1, 2010, at 6:24 AM, Jeremy Shaw wrote:

I would recommend:

cd happstack
chmod +x bin/build-install-all.sh
./bin/build-install-all.sh

This should install the latest version of happstack from darcs which resolves most install problems. I intend to release it any minute now, but I am waiting for a patch to hsp.cabal to be applied.


This had a different problem building happstack itself:

Building happstack-0.4.3...
trhsx: Error at SrcLoc {srcFilename = "src/HSP/IdentityT.hs", srcLine = 73, srcColumn = 1}:
Illegal instance declaration
cabal: Error: some packages failed to install:
happstack-0.4.3 failed during the building phase. The exception was:
ExitFailure 1


I can't see anything that looks obviously wrong with line 73 of that file, but haven't studied it in detail.

Warren


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Daniel Fischer-4
Am Samstag 01 Mai 2010 19:06:33 schrieb Warren Harris:

> On May 1, 2010, at 3:39 AM, Daniel Fischer wrote:
> > Try
> >
> > $ cabal install  --constraint="Crypto<4.2.1" --
> > constraint="HJScript<0.5"
> > happs-tutorial
>
> This had the same problem building containers:
>
> Building containers-0.2.0.1...
>
> Data/IntMap.hs:182:7:
>      Could not find module `Data.Data':
>        It is a member of the hidden package `base'.
>        Perhaps you need to add `base' to the build-depends in
> your .cabal file.
>        Use -v to see a list of the files searched for.
> cabal: Error: some packages failed to install:

That's a slightly misleading error message.
containers-0.2.0.1 lists base as one of its build-dependencies, but without
version constraints. So cabal-install chooses base-3.* as the version for
base, which doesn't have Data.Data. Data.Data first appears in
base-4.0.0.0, so Data.Data is a member of the hidden package base-4.*.

Add a --constraint="base>=4"

That should fix containers-0.2.0.1, but it might break something else.
Or try again with the darcs version.

>
> On May 1, 2010, at 6:24 AM, Jeremy Shaw wrote:
> > I would recommend:
> >
> > darcs get --lazy http://patch-tag.com/r/mae/happstack
> > cd happstack
> > chmod +x bin/build-install-all.sh
> > ./bin/build-install-all.sh
> >
> > This should install the latest version of happstack from darcs which
> > resolves most install problems. I intend to release it any minute
> > now, but I am waiting for a patch to hsp.cabal to be applied.
>
> This had a different problem building happstack itself:
>
> Building happstack-0.4.3...
> trhsx: Error at SrcLoc {srcFilename = "src/HSP/IdentityT.hs", srcLine
> = 73, srcColumn = 1}:
> Illegal instance declaration
> cabal: Error: some packages failed to install:
> happstack-0.4.3 failed during the building phase. The exception was:
> ExitFailure 1
>
>
> I can't see anything that looks obviously wrong with line 73 of that
> file, but haven't studied it in detail.

Maybe a missing {-# LANGUAGE FlexibleInstances #-} (or
TypeSynonymInstances)?

>
> Warren

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Warren Harris

On May 1, 2010, at 10:48 AM, Daniel Fischer wrote:

> Add a --constraint="base>=4"
>
> That should fix containers-0.2.0.1, but it might break something else.

Sorry...

$ cabal install  --constraint="Crypto<4.2.1" --
constraint="HJScript<0.5" --constraint="base>=4" happs-tutorial
Resolving dependencies...
cabal: dependencies conflict: happstack-server-0.4.3 requires containers
==0.3.0.0 however
containers-0.3.0.0 was excluded because happstack-helpers-0.49 requires
containers >=0.2.0.0 && <0.3.0.0
containers-0.3.0.0 was excluded because happs-tutorial-0.9.3 requires
containers >=0.2.0.0 && <0.3.0.0

I think I'll have to wait for Jeremy's update.

Warren
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Build problems (hsp, trhsx, ultimately Happstack)

Alexander Solla-2

On May 1, 2010, at 10:54 AM, Warren Harris wrote:

> I think I'll have to wait for Jeremy's update.

On the plus side, the comments/source in the tutorial are pretty good  
to follow the source along as an example, even if you don't compile  
and run them.  I didn't bother installing happstack-tutorial, I just  
read it and picked and chose what I liked.  If you do install it,  
you'll just be running the same site/content as http://tutorial.happstack.com/


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe