Cabal Libraires help

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Cabal Libraires help

DisFunctional
I am having trouble importing libraries installed with cabal it seem I have two package.conf files and only the first is vaild.
***********************************************************************
$>ghc-pkg list
/usr/local/lib/ghc-6.10.1/./package.conf:
    Cabal-1.6.0.1, HUnit-1.2.0.3, QuickCheck-1.2.0.0, array-0.2.0.0,
    base-3.0.3.0, base-4.0.0.0, bytestring-0.9.1.4, cairo-0.10.0,
    containers-0.2.0.0, directory-1.0.0.2, (dph-base-0.3),
    (dph-par-0.3), (dph-prim-interface-0.3), (dph-prim-par-0.3),
    (dph-prim-seq-0.3), (dph-seq-0.3), editline-0.2.1.0,
    filepath-1.1.0.1, (ghc-6.10.1), ghc-prim-0.1.0.0, gio-0.10.0,
    glade-0.10.0, glib-0.10.0, gtk-0.10.0, gtkglext-0.10.0,
    haddock-2.3.0, haskell-src-1.0.1.3, haskell98-1.0.1.0, hpc-0.5.0.2,
    html-1.0.1.2, integer-0.1.0.0, mtl-1.1.0.2, network-2.2.0.1,
    old-locale-1.0.0.1, old-time-1.0.0.1, packedstring-0.1.0.1,
    parallel-1.1.0.0, parsec-2.1.0.1, pretty-1.0.1.0, process-1.0.1.0,
    random-1.0.0.1, regex-base-0.72.0.2, regex-compat-0.71.0.1,
    regex-posix-0.72.0.3, rts-1.0, soegtk-0.10.0, stm-2.1.1.2,
    syb-0.1.0.0, template-haskell-2.3.0.0, time-1.1.2.2, unix-2.3.1.0,
    wxcore-0.11.0, xhtml-3000.2.0.1
/home/xxxx/.ghc/x86_64-linux-6.10.1/package.conf:
    Cabal-1.6.0.2, GLUT-2.1.1.2, HTTP-4000.0.4, OpenGL-2.2.1.1,
    QuickCheck-2.1.0.1, Stream-0.3.1, Yampa-0.9.2.3, arrows-0.4.1,
    haskell98-1.0.1.0, lazysmallcheck-0.3, plugins-1.4.0,
    process-1.0.1.1, regex-base-0.93.1, regex-posix-0.94.1,
    sqlite-0.4.2, text-0.1, utf8-string-0.3.4, wx-0.11.0, zlib-0.5.0.0
****************************************************************************************

what can I do?