Cabal trouble

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Cabal trouble

GHC - devs mailing list

Trying to build the repro case in Trac #14208, I get this

cabal install --with-ghc=/home/simonpj/5builds/ghc-8.4-branch/inplace/bin/ghc-stage2

Warning: cannot determine version of /home/simonpj/.cabal/bin/c2hs :

""

Resolving dependencies...

cabal: Could not resolve dependencies:

trying: exceptions-0.8.3 (dependency of streamly)

next goal: template-haskell (dependency of exceptions)

rejecting: template-haskell-2.13.0.0/installed-2.1... (conflict: exceptions =>

template-haskell>=2.2 && <2.13)

rejecting: template-haskell-2.12.0.0, template-haskell-2.11.1.0,

template-haskell-2.11.0.0, template-haskell-2.10.0.0,

template-haskell-2.9.0.0, template-haskell-2.8.0.0, template-haskell-2.7.0.0,

template-haskell-2.6.0.0, template-haskell-2.5.0.0, template-haskell-2.4.0.1,

template-haskell-2.4.0.0, template-haskell-2.3.0.1, template-haskell-2.3.0.0,

template-haskell-2.2.0.0 (constraint from non-upgradeable package requires

installed instance)

After searching the rest of the dependency tree exhaustively, these were the

goals I've had most trouble fulfilling: template-haskell, exceptions,

streamly, transformers, base

This is with my in-place build of GHC-8.4 (in-place but not modified in any way).  I’ve done a ‘cabal upate’.

What am I doing wrong?

Thanks

Simon


_______________________________________________
ghc-devs mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs
Reply | Threaded
Open this post in threaded view
|

Re: Cabal trouble

Alp Mestanogullari
Appending `--allow-newer=template-haskell` should tell cabal to ignore upper bounds on that package and consider more recent versions as well. In case the problem really just has to do with bounds and the code itself doesn't care, this should allow you to successfully build that package. You could also say `--allow-newer=exceptions:template-haskell` to ask cabal to ignore the upper bounds that the exceptions package puts on template-haskell. [1] has more to say about option.


On Wed, Mar 28, 2018 at 9:33 AM, Simon Peyton Jones via ghc-devs <[hidden email]> wrote:

Trying to build the repro case in Trac #14208, I get this

cabal install --with-ghc=/home/simonpj/5builds/ghc-8.4-branch/inplace/bin/ghc-stage2

Warning: cannot determine version of /home/simonpj/.cabal/bin/c2hs :

""

Resolving dependencies...

cabal: Could not resolve dependencies:

trying: exceptions-0.8.3 (dependency of streamly)

next goal: template-haskell (dependency of exceptions)

rejecting: template-haskell-2.13.0.0/installed-2.1... (conflict: exceptions =>

template-haskell>=2.2 && <2.13)

rejecting: template-haskell-2.12.0.0, template-haskell-2.11.1.0,

template-haskell-2.11.0.0, template-haskell-2.10.0.0,

template-haskell-2.9.0.0, template-haskell-2.8.0.0, template-haskell-2.7.0.0,

template-haskell-2.6.0.0, template-haskell-2.5.0.0, template-haskell-2.4.0.1,

template-haskell-2.4.0.0, template-haskell-2.3.0.1, template-haskell-2.3.0.0,

template-haskell-2.2.0.0 (constraint from non-upgradeable package requires

installed instance)

After searching the rest of the dependency tree exhaustively, these were the

goals I've had most trouble fulfilling: template-haskell, exceptions,

streamly, transformers, base

This is with my in-place build of GHC-8.4 (in-place but not modified in any way).  I’ve done a ‘cabal upate’.

What am I doing wrong?

Thanks

Simon


_______________________________________________
ghc-devs mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs




--
Alp Mestanogullari

_______________________________________________
ghc-devs mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs