Can't install yesod-platform due to vector package

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't install yesod-platform due to vector package

Sukit Tretriluxana
Hi all,

I'm trying to install Yesod as suggested by this page.


with the following command 

cabal update cabal install yesod-platform yesod-bin --max-backjumps=-1 --reorder-goals

But I constantly get the following error.

...

136 warnings and 6 errors generated.

Failed to install vector-0.10.9.1

cabal: Error: some packages failed to install:

aeson-0.6.2.1 depends on vector-0.10.9.1 which failed to install.

...

The error appears to be from the fact that cabal cannot install vector package.

Any suggestion to fix the problem. I'm on Maverick, Xcode5, Haskell Platform 2013.2.0.0 64bit

Thanks,
Ed

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Can't install yesod-platform due to vector package

Brandon Allbery
On Thu, Jan 16, 2014 at 11:43 AM, Sukit Tretriluxana <[hidden email]> wrote:
Any suggestion to fix the problem. I'm on Maverick, Xcode5, Haskell Platform 2013.2.0.0 64bit

We would have to see the actual errors, as opposed to just how many errors occurred which is all that you have shown us.

But, since you say you are on Mavericks with Xcode 5, have you applied the mandatory changes for Xcode 5 support? http://is.gd/H4sEub

--
brandon s allbery kf8nh                               sine nomine associates
[hidden email]                                  [hidden email]
unix, openafs, kerberos, infrastructure, xmonad        http://sinenomine.net

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Can't install yesod-platform due to vector package

Michael Snoyman
In reply to this post by Sukit Tretriluxana
Can you include the full output from trying to install vector?

    cabal install vector-0.10.9.1


On Thu, Jan 16, 2014 at 6:43 PM, Sukit Tretriluxana <[hidden email]> wrote:
Hi all,

I'm trying to install Yesod as suggested by this page.


with the following command 

cabal update cabal install yesod-platform yesod-bin --max-backjumps=-1 --reorder-goals

But I constantly get the following error.

...

136 warnings and 6 errors generated.

Failed to install vector-0.10.9.1

cabal: Error: some packages failed to install:

aeson-0.6.2.1 depends on vector-0.10.9.1 which failed to install.

...

The error appears to be from the fact that cabal cannot install vector package.

Any suggestion to fix the problem. I'm on Maverick, Xcode5, Haskell Platform 2013.2.0.0 64bit

Thanks,
Ed

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe



_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Can't install yesod-platform due to vector package

Sukit Tretriluxana
Thanks both Brandon and Michael for your help. My bad. I wasn't aware of the small step to take after install Haskell Platform that Brandon pointed out. After done that, everything works just fine.

Ed


On Thu, Jan 16, 2014 at 9:30 AM, Michael Snoyman <[hidden email]> wrote:
Can you include the full output from trying to install vector?

    cabal install vector-0.10.9.1


On Thu, Jan 16, 2014 at 6:43 PM, Sukit Tretriluxana <[hidden email]> wrote:
Hi all,

I'm trying to install Yesod as suggested by this page.


with the following command 

cabal update cabal install yesod-platform yesod-bin --max-backjumps=-1 --reorder-goals

But I constantly get the following error.

...

136 warnings and 6 errors generated.

Failed to install vector-0.10.9.1

cabal: Error: some packages failed to install:

aeson-0.6.2.1 depends on vector-0.10.9.1 which failed to install.

...

The error appears to be from the fact that cabal cannot install vector package.

Any suggestion to fix the problem. I'm on Maverick, Xcode5, Haskell Platform 2013.2.0.0 64bit

Thanks,
Ed

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe




_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe