Couple of problems with leksah

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Couple of problems with leksah

Peter Hall
I didn't get any response on the Leksah forum, so I hope it's ok to ask here.

First problem, I keep seeing this in the error log:

> Setup: You need to re-run the 'configure' command. The version of Cabal being
> used has changed (was Cabal-1.10.2.0, now Cabal-1.10.1.0). Additionally the
> compiler is different (was ghc-6.12, now ghc-7.0) which is probably the cause
> of the problem.

When I run configure, it just prints:

> Resolving dependencies...
> Configuring pokercalc-0.0.1...

But it doesn't fix anything.

The other problem is when I try to update cabal:

> cabal install leksah
Resolving dependencies...
cabal: cannot configure haddock-2.9.4. It requires ghc >=7.2 && <7.4
There is no available version of ghc that satisfies >=7.2 && <7.4


I'm using Haskell Platform 2011.2.0.1 for Mac OS X 10.6
Any ideas?

Peter


Reply | Threaded
Open this post in threaded view
|

Couple of problems with leksah

Daniel Fischer
On Tuesday 08 November 2011, 01:59:47, Peter Hall wrote:
> I didn't get any response on the Leksah forum, so I hope it's ok to ask
> here.

Sure. Anything Haskell-related is okay to ask here.

>
> First problem, I keep seeing this in the error log:
> > Setup: You need to re-run the 'configure' command. The version of
> > Cabal being used has changed (was Cabal-1.10.2.0, now
> > Cabal-1.10.1.0). Additionally the compiler is different (was
> > ghc-6.12, now ghc-7.0) which is probably the cause of the problem.
>
> When I run configure, it just prints:
> > Resolving dependencies...
> > Configuring pokercalc-0.0.1...
>
> But it doesn't fix anything.

Sorry, no idea for that one.

>
> The other problem is when I try to update cabal:
> > cabal install leksah
>
> Resolving dependencies...
> cabal: cannot configure haddock-2.9.4. It requires ghc >=7.2 && <7.4
> There is no available version of ghc that satisfies >=7.2 && <7.4

haddock-2.9.4 is exclusively for ghc-7.2, with ghc-7.0, you need
haddock-2.9.2, try

$ cabal install leksah --constraint="haddock < 2.9.4"
 
>
> I'm using Haskell Platform 2011.2.0.1 for Mac OS X 10.6
> Any ideas?
>
> Peter



Reply | Threaded
Open this post in threaded view
|

Couple of problems with leksah

Peter Hall
Thanks. That got me a bit further, but there are a lot more errors now!

cabal: Error: some packages failed to install:
binary-shared-0.8.1 failed during the building phase. The exception was:
ExitFailure 1
cairo-0.12.1 failed during the configure step. The exception was:
ExitFailure 1
gio-0.12.1 depends on glib-0.12.1 which failed to install.
glib-0.12.1 failed during the configure step. The exception was:
ExitFailure 1
gtk-0.12.1 depends on glib-0.12.1 which failed to install.
gtksourceview2-0.12.3 depends on glib-0.12.1 which failed to install.
haddock-2.9.3 failed during the building phase. The exception was:
ExitFailure 1
hslogger-1.1.5 failed during the building phase. The exception was:
ExitFailure 1
ige-mac-integration-0.1.0.1 depends on glib-0.12.1 which failed to install.
leksah-0.10.0.4 depends on hslogger-1.1.5 which failed to install.
leksah-server-0.10.0.4 depends on hslogger-1.1.5 which failed to install.
ltk-0.10.0.4 depends on haddock-2.9.3 which failed to install.
pango-0.12.1 depends on glib-0.12.1 which failed to install.



Peter


On Tue, Nov 8, 2011 at 1:18 AM, Daniel Fischer
<daniel.is.fischer at googlemail.com> wrote:

> On Tuesday 08 November 2011, 01:59:47, Peter Hall wrote:
>> I didn't get any response on the Leksah forum, so I hope it's ok to ask
>> here.
>
> Sure. Anything Haskell-related is okay to ask here.
>
>>
>> First problem, I keep seeing this in the error log:
>> > Setup: You need to re-run the 'configure' command. The version of
>> > Cabal being used has changed (was Cabal-1.10.2.0, now
>> > Cabal-1.10.1.0). Additionally the compiler is different (was
>> > ghc-6.12, now ghc-7.0) which is probably the cause of the problem.
>>
>> When I run configure, it just prints:
>> > Resolving dependencies...
>> > Configuring pokercalc-0.0.1...
>>
>> But it doesn't fix anything.
>
> Sorry, no idea for that one.
>
>>
>> The other problem is when I try to update cabal:
>> > cabal install leksah
>>
>> Resolving dependencies...
>> cabal: cannot configure haddock-2.9.4. It requires ghc >=7.2 && <7.4
>> There is no available version of ghc that satisfies >=7.2 && <7.4
>
> haddock-2.9.4 is exclusively for ghc-7.2, with ghc-7.0, you need
> haddock-2.9.2, try
>
> $ cabal install leksah --constraint="haddock < 2.9.4"
>
>>
>> I'm using Haskell Platform 2011.2.0.1 for Mac OS X 10.6
>> Any ideas?
>>
>> Peter
>
>


Reply | Threaded
Open this post in threaded view
|

Couple of problems with leksah

Peter Hall
I still haven't managed to resolve this. Any thoughts on the errors below?

I don't understand why packages should be on hackage in the first
place if their dependencies are not available from there either. I
feel like you should have to explicitly opt-in to get any package that
has non-hackage or unreleased dependencies.

Peter


On Tue, Nov 8, 2011 at 1:47 AM, Peter Hall <peter.hall at memorphic.com> wrote:

> Thanks. That got me a bit further, but there are a lot more errors now!
>
> cabal: Error: some packages failed to install:
> binary-shared-0.8.1 failed during the building phase. The exception was:
> ExitFailure 1
> cairo-0.12.1 failed during the configure step. The exception was:
> ExitFailure 1
> gio-0.12.1 depends on glib-0.12.1 which failed to install.
> glib-0.12.1 failed during the configure step. The exception was:
> ExitFailure 1
> gtk-0.12.1 depends on glib-0.12.1 which failed to install.
> gtksourceview2-0.12.3 depends on glib-0.12.1 which failed to install.
> haddock-2.9.3 failed during the building phase. The exception was:
> ExitFailure 1
> hslogger-1.1.5 failed during the building phase. The exception was:
> ExitFailure 1
> ige-mac-integration-0.1.0.1 depends on glib-0.12.1 which failed to install.
> leksah-0.10.0.4 depends on hslogger-1.1.5 which failed to install.
> leksah-server-0.10.0.4 depends on hslogger-1.1.5 which failed to install.
> ltk-0.10.0.4 depends on haddock-2.9.3 which failed to install.
> pango-0.12.1 depends on glib-0.12.1 which failed to install.
>
>
>
> Peter
>
>
> On Tue, Nov 8, 2011 at 1:18 AM, Daniel Fischer
> <daniel.is.fischer at googlemail.com> wrote:
>> On Tuesday 08 November 2011, 01:59:47, Peter Hall wrote:
>>> I didn't get any response on the Leksah forum, so I hope it's ok to ask
>>> here.
>>
>> Sure. Anything Haskell-related is okay to ask here.
>>
>>>
>>> First problem, I keep seeing this in the error log:
>>> > Setup: You need to re-run the 'configure' command. The version of
>>> > Cabal being used has changed (was Cabal-1.10.2.0, now
>>> > Cabal-1.10.1.0). Additionally the compiler is different (was
>>> > ghc-6.12, now ghc-7.0) which is probably the cause of the problem.
>>>
>>> When I run configure, it just prints:
>>> > Resolving dependencies...
>>> > Configuring pokercalc-0.0.1...
>>>
>>> But it doesn't fix anything.
>>
>> Sorry, no idea for that one.
>>
>>>
>>> The other problem is when I try to update cabal:
>>> > cabal install leksah
>>>
>>> Resolving dependencies...
>>> cabal: cannot configure haddock-2.9.4. It requires ghc >=7.2 && <7.4
>>> There is no available version of ghc that satisfies >=7.2 && <7.4
>>
>> haddock-2.9.4 is exclusively for ghc-7.2, with ghc-7.0, you need
>> haddock-2.9.2, try
>>
>> $ cabal install leksah --constraint="haddock < 2.9.4"
>>
>>>
>>> I'm using Haskell Platform 2011.2.0.1 for Mac OS X 10.6
>>> Any ideas?
>>>
>>> Peter
>>
>>
>


Reply | Threaded
Open this post in threaded view
|

Couple of problems with leksah

Daniel Fischer
On Saturday 12 November 2011, 17:32:10, Peter Hall wrote:
> I still haven't managed to resolve this. Any thoughts on the errors
> below?

No idea why binary-shared failed to build. For more info, try to cabal-
install it with a higher verbosity level,

$ cabal install binary-shared -v2

(perhaps even -v3).

The other errors may be cascading from failing to build any gtk2hs package.
To install gtk2hs packages, you have to first

$ cabal install gtk2hs-buildtools

(that package contains only executables, no library, hence can't be a
build-depend in the cabal file, alas). If you already have the buildtools
somewhere in your path,

$ which gtk2hsC2hs

would be a quick test, something else has gone awry. Then try to manually
install one of the gtk2hs packages, iirc, cairo doesn't depend on any
other, so

$ cabal install cairo -v2

Hopefully the messages printed to stderr would allow to find out what
broke.

>
> I don't understand why packages should be on hackage in the first
> place if their dependencies are not available from there either. I

Are there packages on hackage with Haskell dependencies not available on
hackage? That would be bad. (If C dependencies are not available from
hackage, that's inconvenient, but natural.)

> feel like you should have to explicitly opt-in to get any package that
> has non-hackage or unreleased dependencies.

Agreed.

>
> Peter
>
> On Tue, Nov 8, 2011 at 1:47 AM, Peter Hall <peter.hall at memorphic.com>
wrote:

> > Thanks. That got me a bit further, but there are a lot more errors
> > now!
> >
> > cabal: Error: some packages failed to install:
> > binary-shared-0.8.1 failed during the building phase. The exception
> > was: ExitFailure 1
> > cairo-0.12.1 failed during the configure step. The exception was:
> > ExitFailure 1
> > gio-0.12.1 depends on glib-0.12.1 which failed to install.
> > glib-0.12.1 failed during the configure step. The exception was:
> > ExitFailure 1
> > gtk-0.12.1 depends on glib-0.12.1 which failed to install.
> > gtksourceview2-0.12.3 depends on glib-0.12.1 which failed to install.
> > haddock-2.9.3 failed during the building phase. The exception was:
> > ExitFailure 1
> > hslogger-1.1.5 failed during the building phase. The exception was:
> > ExitFailure 1
> > ige-mac-integration-0.1.0.1 depends on glib-0.12.1 which failed to
> > install. leksah-0.10.0.4 depends on hslogger-1.1.5 which failed to
> > install. leksah-server-0.10.0.4 depends on hslogger-1.1.5 which
> > failed to install. ltk-0.10.0.4 depends on haddock-2.9.3 which failed
> > to install. pango-0.12.1 depends on glib-0.12.1 which failed to
> > install.
> >
> >
> >
> > Peter
> >