Damn you hmatrix

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Damn you hmatrix

Yotam Ohad
Hi cafe,
I have a very annoying problem with hmatrix. I have a project which depends on it. I can use `stack build` with no errors but when I try to load it to GHCi(`stack ghci`) I get the following error:
sh-4.3$ stack ghci
[0mApple-0.1.0.0: configure (lib) [0m
[0mConfiguring Apple-0.1.0.0... [0m
[0mApple-0.1.0.0: initial-build-steps (lib) [0m
[0mConfiguring GHCi with the following packages: Apple [0m
GHCi, version 8.0.2: http://www.haskell.org/ghc/  :? for help
ghc.EXE: addDLL: libblas.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `libblas.dll'. Reason: addDLL: could not load DLL

ghc.EXE: addDLL: liblapack.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `liblapack.dll'. Reason: addDLL: could not load DLL

ghc.EXE: C:\Users\Yotam\Apple\.stack-work\install\ebd7be2b\lib\x86_64-windows-ghc-8.0.2\hmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ\HShmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ.o: unknown symbol `dgesvd_'

ghc.EXE: unable to load package `hmatrix-0.18.0.0'

This is really bizarre, and could not find something online to help me fix this.
I'm using stack 1.5.0 with ghc 8.0.2

On a side note, I've seen some discussions about why the C libraries can't be added automatically but did not understand most of it, if someone can explain it would be highly appreciated.

Yotam



_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Damn you hmatrix

Dan Burton

-- Dan Burton

On Thu, Jul 27, 2017 at 9:02 AM, Yotam Ohad <[hidden email]> wrote:
Hi cafe,
I have a very annoying problem with hmatrix. I have a project which depends on it. I can use `stack build` with no errors but when I try to load it to GHCi(`stack ghci`) I get the following error:
sh-4.3$ stack ghci
[0mApple-0.1.0.0: configure (lib) [0m
[0mConfiguring Apple-0.1.0.0... [0m
[0mApple-0.1.0.0: initial-build-steps (lib) [0m
[0mConfiguring GHCi with the following packages: Apple [0m
GHCi, version 8.0.2: http://www.haskell.org/ghc/  :? for help
ghc.EXE: addDLL: libblas.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `libblas.dll'. Reason: addDLL: could not load DLL

ghc.EXE: addDLL: liblapack.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `liblapack.dll'. Reason: addDLL: could not load DLL

ghc.EXE: C:\Users\Yotam\Apple\.stack-work\install\ebd7be2b\lib\x86_64-windows-ghc-8.0.2\hmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ\HShmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ.o: unknown symbol `dgesvd_'

ghc.EXE: unable to load package `hmatrix-0.18.0.0'

This is really bizarre, and could not find something online to help me fix this.
I'm using stack 1.5.0 with ghc 8.0.2

On a side note, I've seen some discussions about why the C libraries can't be added automatically but did not understand most of it, if someone can explain it would be highly appreciated.

Yotam



_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.


_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Damn you hmatrix

Yotam Ohad
I did not see this guide, but even when I follow the instruction when I try to install hmatrix as in the last step of the guide and get a /missing C library: libgfortran-3.
All the actions I described in the first email have resulted in the same results.

Yotam

‫בתאריך יום ה׳, 27 ביולי 2017 ב-22:31 מאת ‪Dan Burton‬‏ <‪[hidden email]‬‏>:‬

-- Dan Burton

On Thu, Jul 27, 2017 at 9:02 AM, Yotam Ohad <[hidden email]> wrote:
Hi cafe,
I have a very annoying problem with hmatrix. I have a project which depends on it. I can use `stack build` with no errors but when I try to load it to GHCi(`stack ghci`) I get the following error:
sh-4.3$ stack ghci
[0mApple-0.1.0.0: configure (lib) [0m
[0mConfiguring Apple-0.1.0.0... [0m
[0mApple-0.1.0.0: initial-build-steps (lib) [0m
[0mConfiguring GHCi with the following packages: Apple [0m
GHCi, version 8.0.2: http://www.haskell.org/ghc/  :? for help
ghc.EXE: addDLL: libblas.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `libblas.dll'. Reason: addDLL: could not load DLL

ghc.EXE: addDLL: liblapack.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `liblapack.dll'. Reason: addDLL: could not load DLL

ghc.EXE: C:\Users\Yotam\Apple\.stack-work\install\ebd7be2b\lib\x86_64-windows-ghc-8.0.2\hmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ\HShmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ.o: unknown symbol `dgesvd_'

ghc.EXE: unable to load package `hmatrix-0.18.0.0'

This is really bizarre, and could not find something online to help me fix this.
I'm using stack 1.5.0 with ghc 8.0.2

On a side note, I've seen some discussions about why the C libraries can't be added automatically but did not understand most of it, if someone can explain it would be highly appreciated.

Yotam



_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.


_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Damn you hmatrix

bruno
Just rename/copy/link libgfortran-3 to libgfortran
I solved the same problem this way

On 28 Jul 2017, 12:32 +0200, Yotam Ohad <[hidden email]>, wrote:
I did not see this guide, but even when I follow the instruction when I try to install hmatrix as in the last step of the guide and get a /missing C library: libgfortran-3.
All the actions I described in the first email have resulted in the same results.

Yotam

‫בתאריך יום ה׳, 27 ביולי 2017 ב-22:31 מאת ‪Dan Burton‬‏ <‪[hidden email]‬‏>:‬

-- Dan Burton

On Thu, Jul 27, 2017 at 9:02 AM, Yotam Ohad <[hidden email]> wrote:
Hi cafe,
I have a very annoying problem with hmatrix. I have a project which depends on it. I can use `stack build` with no errors but when I try to load it to GHCi(`stack ghci`) I get the following error:
sh-4.3$ stack ghci
[0mApple-0.1.0.0: configure (lib) [0m
[0mConfiguring Apple-0.1.0.0... [0m
[0mApple-0.1.0.0: initial-build-steps (lib) [0m
[0mConfiguring GHCi with the following packages: Apple [0m
GHCi, version 8.0.2: http://www.haskell.org/ghc/  :? for help
ghc.EXE: addDLL: libblas.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `libblas.dll'. Reason: addDLL: could not load DLL

ghc.EXE: addDLL: liblapack.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `liblapack.dll'. Reason: addDLL: could not load DLL

ghc.EXE: C:\Users\Yotam\Apple\.stack-work\install\ebd7be2b\lib\x86_64-windows-ghc-8.0.2\hmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ\HShmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ.o: unknown symbol `dgesvd_'

ghc.EXE: unable to load package `hmatrix-0.18.0.0'

This is really bizarre, and could not find something online to help me fix this.
I'm using stack 1.5.0 with ghc 8.0.2

On a side note, I've seen some discussions about why the C libraries can't be added automatically but did not understand most of it, if someone can explain it would be highly appreciated.

Yotam



_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Damn you hmatrix

Yotam Ohad
Could you explain in more details? I've searched through the files (both on the msys folder and OpenBlas folder) but could not find a file called libgfortran/libgfortran-3

‫בתאריך שבת, 29 ביולי 2017 ב-11:14 מאת <‪[hidden email]‬‏>:‬
Just rename/copy/link libgfortran-3 to libgfortran
I solved the same problem this way

On 28 Jul 2017, 12:32 +0200, Yotam Ohad <[hidden email]>, wrote:
I did not see this guide, but even when I follow the instruction when I try to install hmatrix as in the last step of the guide and get a /missing C library: libgfortran-3.
All the actions I described in the first email have resulted in the same results.

Yotam

‫בתאריך יום ה׳, 27 ביולי 2017 ב-22:31 מאת ‪Dan Burton‬‏ <‪[hidden email]‬‏>:‬

-- Dan Burton

On Thu, Jul 27, 2017 at 9:02 AM, Yotam Ohad <[hidden email]> wrote:
Hi cafe,
I have a very annoying problem with hmatrix. I have a project which depends on it. I can use `stack build` with no errors but when I try to load it to GHCi(`stack ghci`) I get the following error:
sh-4.3$ stack ghci
[0mApple-0.1.0.0: configure (lib) [0m
[0mConfiguring Apple-0.1.0.0... [0m
[0mApple-0.1.0.0: initial-build-steps (lib) [0m
[0mConfiguring GHCi with the following packages: Apple [0m
GHCi, version 8.0.2: http://www.haskell.org/ghc/  :? for help
ghc.EXE: addDLL: libblas.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `libblas.dll'. Reason: addDLL: could not load DLL

ghc.EXE: addDLL: liblapack.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `liblapack.dll'. Reason: addDLL: could not load DLL

ghc.EXE: C:\Users\Yotam\Apple\.stack-work\install\ebd7be2b\lib\x86_64-windows-ghc-8.0.2\hmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ\HShmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ.o: unknown symbol `dgesvd_'

ghc.EXE: unable to load package `hmatrix-0.18.0.0'

This is really bizarre, and could not find something online to help me fix this.
I'm using stack 1.5.0 with ghc 8.0.2

On a side note, I've seen some discussions about why the C libraries can't be added automatically but did not understand most of it, if someone can explain it would be highly appreciated.

Yotam



_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Damn you hmatrix

bruno
Well in my installation (windows) there is a libgfortran-3.dll in msys2-20150512/mingw64/bin

On 29 Jul 2017, 12:31 +0200, Yotam Ohad <[hidden email]>, wrote:
Could you explain in more details? I've searched through the files (both on the msys folder and OpenBlas folder) but could not find a file called libgfortran/libgfortran-3

‫בתאריך שבת, 29 ביולי 2017 ב-11:14 מאת <‪[hidden email]‬‏>:‬
Just rename/copy/link libgfortran-3 to libgfortran
I solved the same problem this way

On 28 Jul 2017, 12:32 +0200, Yotam Ohad <[hidden email]>, wrote:
I did not see this guide, but even when I follow the instruction when I try to install hmatrix as in the last step of the guide and get a /missing C library: libgfortran-3.
All the actions I described in the first email have resulted in the same results.

Yotam

‫בתאריך יום ה׳, 27 ביולי 2017 ב-22:31 מאת ‪Dan Burton‬‏ <‪[hidden email]‬‏>:‬

-- Dan Burton

On Thu, Jul 27, 2017 at 9:02 AM, Yotam Ohad <[hidden email]> wrote:
Hi cafe,
I have a very annoying problem with hmatrix. I have a project which depends on it. I can use `stack build` with no errors but when I try to load it to GHCi(`stack ghci`) I get the following error:
sh-4.3$ stack ghci
[0mApple-0.1.0.0: configure (lib) [0m
[0mConfiguring Apple-0.1.0.0... [0m
[0mApple-0.1.0.0: initial-build-steps (lib) [0m
[0mConfiguring GHCi with the following packages: Apple [0m
GHCi, version 8.0.2: http://www.haskell.org/ghc/  :? for help
ghc.EXE: addDLL: libblas.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `libblas.dll'. Reason: addDLL: could not load DLL

ghc.EXE: addDLL: liblapack.dll (Win32 error 126): The specified module could not be found.
ghc.EXE: Could not load `liblapack.dll'. Reason: addDLL: could not load DLL

ghc.EXE: C:\Users\Yotam\Apple\.stack-work\install\ebd7be2b\lib\x86_64-windows-ghc-8.0.2\hmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ\HShmatrix-0.18.0.0-IA7RzrKn1o84vo5PLhGcwQ.o: unknown symbol `dgesvd_'

ghc.EXE: unable to load package `hmatrix-0.18.0.0'

This is really bizarre, and could not find something online to help me fix this.
I'm using stack 1.5.0 with ghc 8.0.2

On a side note, I've seen some discussions about why the C libraries can't be added automatically but did not understand most of it, if someone can explain it would be highly appreciated.

Yotam



_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.
Loading...