Different results when building wxHaskell on Cabal and Stack

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Different results when building wxHaskell on Cabal and Stack

Yotam Ohad
Hello cafe,
Lately, I wanted to try wxHaskell, so I downloaded and install wxWidgets and added the necessary paths to %PATH%. The problem was that when trying to build, cabal would have no problem at all, while stack sends me into battle with my path, complaining about missing header and executable files and so on.

I don't understand why stack is having such a hard time when cabal has no trouble at all. I know that they are not the same, but I still think that it is weird that stack is acting like that.

Thanks for your help,
Yotam

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.
Reply | Threaded
Open this post in threaded view
|

Re: Different results when building wxHaskell on Cabal and Stack

Michael Snoyman
It's impossible to say why the results are different in this case without more information. For example:

* Where did you install wxWidgets?
* How did you modify PATH? Did you modify any other env vars?
* How did you install Cabal and GHC?
* How are you setting env vars? Are you sure Stack is seeing the same values as cabal?
* Are you using the same versions of libraries and compilers with Stack and Cabal?
* What error message are you seeing?

I can't say that I've personally installed wxWidgets recently (on any OS actually), so I don't have personal experience to back it up. But with other libraries (like libicu), I've found that the easiest thing with Stack is to use msys2 and pacman to install the system libraries. As an example, see this tweet[1].

Michael

[1] https://twitter.com/snoyberg/status/638359459304239104

On Sun, Jun 4, 2017 at 4:03 PM, Yotam Ohad <[hidden email]> wrote:
Hello cafe,
Lately, I wanted to try wxHaskell, so I downloaded and install wxWidgets and added the necessary paths to %PATH%. The problem was that when trying to build, cabal would have no problem at all, while stack sends me into battle with my path, complaining about missing header and executable files and so on.

I don't understand why stack is having such a hard time when cabal has no trouble at all. I know that they are not the same, but I still think that it is weird that stack is acting like that.

Thanks for your help,
Yotam

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.


_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.