GHC 7.10.1 / cabal-install 1.22 Ubuntu-PPA pre-RC snapshots available!

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

GHC 7.10.1 / cabal-install 1.22 Ubuntu-PPA pre-RC snapshots available!

Herbert Valerio Riedel
To early adopters & multi-ghc-travis users,

I've uploaded pre-RC snapshots for GHC 7.10.1 and cabal-install 1.22
to my GHC PPA[1], so you can start extending your .travis.yml files w/

  CABALVER=1.22 GHCVER=7.10.1

There are no official RCs yet for GHC 7.10/cabal-install 1.22, these are
merely snapshots from the respective Git branches which I'll keep
updating regularly (every 1-3 days) till the final proper release for
GHC 7.10.1 and cabal-install 1.22.0.0 occur, at which point those
packages (`ghc-7.10-*` & `cabal-install-1.22`) will install the final
release versions.

The usual official release-candidates (including respective
announcements) for GHC & cabal will follow soon.

So please, help us finding issues/bugs with these pre-RC snapshots of
GHC & cabal-install. Obviously, it's desirable to become aware of any
serious issues ASAP, as opposed to shortly before the planned final
release date...

As these are Git snapshots, when reporting bugs/issues, please also
provide the snapshot's Git commit id (which uniquely identifies the GHC
source-tree state), which can be queried via a new GHC CLI option, e.g.:

  $ ghc --print-project-git-commit-id
  a8c556dfca3eca5277615cc2bf9d6c8f1f143c9a

Here's an example build using 7.10.1 to show those packages actually
work:

  https://travis-ci.org/haskell/unix/builds/44919992


 [1]: https://github.com/hvr/multi-ghc-travis
      https://launchpad.net/~hvr/+archive/ubuntu/ghc
 

Cheers,
  hvr


PS: If you happen to run into compile errors for Hackage packages which
    claim to work with GHC 7.10.1 (e.g. by allowing `base-4.8`), I'd be
    interested to hear about it.