Hackage: Tarball and package description of package mtl differ

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Hackage: Tarball and package description of package mtl differ

Björn Peemöller-2
Hi Cafe,

I just wanted to install the mtl package for GHC 8.0.1-rc2, but
installation failed with

  Setup: Encountered missing dependencies:
  transformers ==0.4.*

Taking a look at the package description [1], it specifies

  build-depends: base < 6, transformers >= 0.4 && < 0.6

but the Cabal description in the tarball [2] says

  build-depends: base < 6, transformers == 0.4.*

Strangely, if I execute

  $ cabal unpack mtl-2.2.1

I obtain a version with the same specification as [1].

Does anybody has an explanation for this?

Regards,
Björn

[1]: http://hackage.haskell.org/package/mtl-2.2.1/mtl.cabal
[2]: http://hackage.haskell.org/package/mtl-2.2.1/mtl-2.2.1.tar.gz
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Hackage: Tarball and package description of package mtl differ

Adam Bergmark-2
This is because a revision to the cabal file was published[1]. Tarballs always stay the same (because of possible signing, etc) but cabal-install will use the revised metadata when doing most of its operation including `install', `get', and `unpack'.

You don't say how you are trying to install mtl, is it not through Cabal? Either  way, make sure to use the revised cabal file and it should be fine.

HTH,
Adam


On Wed, Feb 10, 2016 at 3:09 PM, Björn Peemöller <[hidden email]> wrote:
Hi Cafe,

I just wanted to install the mtl package for GHC 8.0.1-rc2, but
installation failed with

  Setup: Encountered missing dependencies:
  transformers ==0.4.*

Taking a look at the package description [1], it specifies

  build-depends: base < 6, transformers >= 0.4 && < 0.6

but the Cabal description in the tarball [2] says

  build-depends: base < 6, transformers == 0.4.*

Strangely, if I execute

  $ cabal unpack mtl-2.2.1

I obtain a version with the same specification as [1].

Does anybody has an explanation for this?

Regards,
Björn

[1]: http://hackage.haskell.org/package/mtl-2.2.1/mtl.cabal
[2]: http://hackage.haskell.org/package/mtl-2.2.1/mtl-2.2.1.tar.gz
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Hackage: Tarball and package description of package mtl differ

Björn Peemöller-2
Am 10.02.2016 um 15:18 schrieb Adam Bergmark:
> This is because a revision to the cabal file was published[1]. Tarballs
> always stay the same (because of possible signing, etc) but
> cabal-install will use the revised metadata when doing most of its
> operation including `install', `get', and `unpack'.

Hi Adam,

thank you for the explanation. I tried to install cabal-install taken
from GitHub for GHC 8.0.0.rc2 via the included `bootstrap.sh` script,
which essentially obtains the tarball from hackage using `curl` and then
calls

$ cd mtl-2.2.1
$ ghc --make Setup.hs -o Setup
$ ./configure # + additional options

> You don't say how you are trying to install mtl, is it not through
> Cabal? Either  way, make sure to use the revised cabal file and it
> should be fine.

Okay, I will then install mtl by hand and try the bootstrap script
afterwards.

Thanks,
Björn
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe