[Haddock] error: utils/haddock_dist_PROGNAME is not set

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Haddock] error: utils/haddock_dist_PROGNAME is not set

David Waern-2
Not sure what's wrong here. Maybe someone on ghc-devs@ knows.

David

2013/3/24 Rob Stewart <robstewart57 at gmail.com>

> Hi,
>
> I am not able to build ghc 7.6 from source, and come across an error
> in utils/haddock/ghc.mk
>
> $ cd ghc
> $ ./sync-all -r http://darcs.haskell.org --extra get -b ghc-7.6
> $ ./sync-all -r http://darcs.haskell.org --extra get # get
> libraries/parallel and libraries/xhtml
> $ perl boot
> $ ./configure --prefix=/home/foo/bar/
> $ make
> + test -f mk/config.mk.old
> + cp -p mk/config.mk mk/config.mk.old
> touch -r mk/config.mk.old mk/config.mk
> + test -f mk/project.mk.old
> + cp -p mk/project.mk mk/project.mk.old
> touch -r mk/project.mk.old mk/project.mk
> + test -f compiler/ghc.cabal.old
> + cp -p compiler/ghc.cabal compiler/ghc.cabal.old
> touch -r compiler/ghc.cabal.old compiler/ghc.cabal
> ===--- building phase 0
> make -r --no-print-directory -f ghc.mk phase=0 phase_0_builds
> libraries/hpc/ghc.mk:3: libraries/hpc/dist-boot/package-data.mk: No
> such file or directory
> libraries/Cabal/Cabal/ghc.mk:3:
> libraries/Cabal/Cabal/dist-boot/package-data.mk: No such file or
> directory
> libraries/bin-package-db/ghc.mk:3:
> libraries/bin-package-db/dist-boot/package-data.mk: No such file or
> directory
> libraries/hoopl/ghc.mk:3: libraries/hoopl/dist-boot/package-data.mk:
> No such file or directory
> libraries/transformers/ghc.mk:3:
> libraries/transformers/dist-boot/package-data.mk: No such file or
> directory
> libraries/terminfo/ghc.mk:3:
> libraries/terminfo/dist-boot/package-data.mk: No such file or
> directory
> utils/haddock/ghc.mk:28: *** utils/haddock_dist_PROGNAME is not set.
>  Stop.
>
> --
> Rob
>
> _______________________________________________
> Haddock mailing list
> Haddock at projects.haskell.org
> http://projects.haskell.org/cgi-bin/mailman/listinfo/haddock
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/ghc-devs/attachments/20130324/5babf4f8/attachment.htm>

Reply | Threaded
Open this post in threaded view
|

[Haddock] error: utils/haddock_dist_PROGNAME is not set

Ian Lynagh-2
On Sun, Mar 24, 2013 at 07:50:34PM +0100, David Waern wrote:
> Not sure what's wrong here. Maybe someone on ghc-devs@ knows.
>
> 2013/3/24 Rob Stewart <robstewart57 at gmail.com>
>
> > I am not able to build ghc 7.6 from source, and come across an error
> > in utils/haddock/ghc.mk
> >
> > utils/haddock/ghc.mk:28: *** utils/haddock_dist_PROGNAME is not set.

I suspect that either your haddock repository is out-of-date, or that
some of your repositories are on the 7.6 branch and some are on master.


Thanks
Ian



Reply | Threaded
Open this post in threaded view
|

Fwd: [Haddock] error: utils/haddock_dist_PROGNAME is not set

Rob Stewart-2
Hi Ian,

That may well be true. However, I ran multiple ./sync-all commands,
due to the following error that I am seeing with the parallel library:

$ ./sync-all -r http://darcs.haskell.org --extra get -b ghc-7.6
...
Cloning into 'libraries/process'...
== libraries/process: running git config --local core.ignorecase true
== running git clone
http://darcs.haskell.org/packages/template-haskell.git
libraries/template-haskell -b ghc-7.6
Cloning into 'libraries/template-haskell'...
== libraries/template-haskell: running git config --local core.ignorecase true
== running git clone http://darcs.haskell.org/packages/unix.git
libraries/unix -b ghc-7.6
Cloning into 'libraries/unix'...
== libraries/unix: running git config --local core.ignorecase true
== running git clone http://darcs.haskell.org/packages/parallel.git
libraries/parallel -b ghc-7.6
Cloning into 'libraries/parallel'...
fatal: Remote branch ghc-7.6 not found in upstream origin
Unexpected end of command stream
git failed: 32768 at ./sync-all line 193.

--
Rob

On 24 March 2013 19:03, Ian Lynagh <ian at well-typed.com> wrote:

> On Sun, Mar 24, 2013 at 07:50:34PM +0100, David Waern wrote:
>> Not sure what's wrong here. Maybe someone on ghc-devs@ knows.
>>
>> 2013/3/24 Rob Stewart <robstewart57 at gmail.com>
>>
>> > I am not able to build ghc 7.6 from source, and come across an error
>> > in utils/haddock/ghc.mk
>> >
>> > utils/haddock/ghc.mk:28: *** utils/haddock_dist_PROGNAME is not set.
>
> I suspect that either your haddock repository is out-of-date, or that
> some of your repositories are on the 7.6 branch and some are on master.
>
>
> Thanks
> Ian
>