Haskell Platform install fails on mtl

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Haskell Platform install fails on mtl

Lyle Kopnicky
OK, I was able to build the Haskell Platform on Ubuntu 9.04 with GHC 6.10.4. But when I try to install it, I get an error:

Registering haskell-platform-2009.2.0.2...
Reading package info from "dist/inplace-pkg-config" ... done.
Writing new package config file... done.
**************************************************

* Building each component completed successfully.
*                                                
* Now do "sudo make install"                     
**************************************************
lwk@lwk-desktop:~/downloads/haskell-platform-2009.2.0.2$ sudo make install
[sudo] password for lwk:
scripts/install.sh
Installing mtl-1.1.0.2...

Error:
The mtl-1.1.0.2/Setup script does not exist or cannot be run
make: *** [install] Error 2

- Lyle

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Haskell Platform install fails on mtl

Lyle Kopnicky
It's a bug in the install.sh script. Here's the fix:

36a37,42
> # Is this exact version of the package already installed?
> is_pkg_installed () {
>   PKG_VER=$1
>   grep " ${PKG_VER} " installed.packages > /dev/null 2>&1
> }
>
40,43c46,53
<   cd "${pkg}" || die "The directory for the component ${PKG} is missing"
<   echo "Installing ${pkg}..."
<   install_pkg ${pkg}
<   cd ..
---
>   if is_pkg_installed "${pkg}"; then
>     echo "Platform package ${pkg} is already installed. Skipping..."
>   else
>       cd "${pkg}" || die "The directory for the component ${PKG} is missing"
>       echo "Installing ${pkg}..."
>       install_pkg ${pkg}
>       cd ..
>   fi

On Fri, Sep 11, 2009 at 1:04 PM, Lyle Kopnicky <[hidden email]> wrote:
OK, I was able to build the Haskell Platform on Ubuntu 9.04 with GHC 6.10.4. But when I try to install it, I get an error:

Registering haskell-platform-2009.2.0.2...
Reading package info from "dist/inplace-pkg-config" ... done.
Writing new package config file... done.
**************************************************

* Building each component completed successfully.
*                                                
* Now do "sudo make install"                     
**************************************************
lwk@lwk-desktop:~/downloads/haskell-platform-2009.2.0.2$ sudo make install
[sudo] password for lwk:
scripts/install.sh
Installing mtl-1.1.0.2...

Error:
The mtl-1.1.0.2/Setup script does not exist or cannot be run
make: *** [install] Error 2

- Lyle


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe