Hint & Cabal Install weirdness.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Hint & Cabal Install weirdness.

jfredett
I'm attempting to install hint, I started by doing:
 
cabal install hint

and it gives me the following error:

cabal: dependencies conflict: ghc-6.10.1 requires process ==1.0.1.1 however
process-1.0.1.1 was excluded because ghc-6.10.1 requires process ==1.0.1.0

So I decided to try installing it via darcs, expecting to either have it
work, or boil it down to one or two dependencies that were causing the
problem, my hunch was right, it boils down to the ghc-mtl package,
leading to the same error as above. My question is, how can I fix this?
Doing a ghc-pkg hide on either process package breaks Cabal and Haddock
(among others) according to the error message, and even after that
happens, cabal complains about needing ghc >= 6.6 (or 6.8, depending on
which package I disable), even though I have ghc 6.10.

Detailed system info follows, help me haskell-cafe-kenobi(s), you're
(all) my only hope(s)!

Sysinfo:

Arch Linux: uname -a gives:
Linux Erdos 2.6.28-ARCH #1 SMP PREEMPT Mon Feb 2 22:22:59 UTC 2009 i686
Intel(R) Celeron(R) CPU 3.06GHz GenuineIntel GNU/Linux

ghc --version gives:
The Glorious Glasgow Haskell Compilation System, version 6.10.1

cabal --version:
cabal-install version 0.6.0
using version 1.6.0.1 of the Cabal library

Thanks again,

/Joe

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe

jfredett.vcf (308 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Hint & Cabal Install weirdness.

Daniel Fischer-4
Am Montag, 2. März 2009 05:24 schrieb Joseph Fredette:
> I'm attempting to install hint, I started by doing:
>
> cabal install hint
>
> and it gives me the following error:
>
> cabal: dependencies conflict: ghc-6.10.1 requires process ==1.0.1.1 however
> process-1.0.1.1 was excluded because ghc-6.10.1 requires process ==1.0.1.0
>

That seems to be *the* most frequent problem this year.

Duncan Coutts explained the matter in
http://haskell.org/pipermail/haskell-cafe/2009-January/054523.html

Hopefully one of the process packages is in the user db, if both are in the
global db, it might be necessary to reinstall ghc.

> So I decided to try installing it via darcs, expecting to either have it
> work, or boil it down to one or two dependencies that were causing the
> problem, my hunch was right, it boils down to the ghc-mtl package,
> leading to the same error as above. My question is, how can I fix this?
> Doing a ghc-pkg hide on either process package breaks Cabal and Haddock
> (among others) according to the error message, and even after that
> happens, cabal complains about needing ghc >= 6.6 (or 6.8, depending on
> which package I disable), even though I have ghc 6.10.
>
> Detailed system info follows, help me haskell-cafe-kenobi(s), you're
> (all) my only hope(s)!
>
> Sysinfo:
>
> Arch Linux: uname -a gives:
> Linux Erdos 2.6.28-ARCH #1 SMP PREEMPT Mon Feb 2 22:22:59 UTC 2009 i686
> Intel(R) Celeron(R) CPU 3.06GHz GenuineIntel GNU/Linux
>
> ghc --version gives:
> The Glorious Glasgow Haskell Compilation System, version 6.10.1
>
> cabal --version:
> cabal-install version 0.6.0
> using version 1.6.0.1 of the Cabal library
>
> Thanks again,
>
> /Joe

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Hint & Cabal Install weirdness.

jfredett
Unregistering and then reinstalling the packages it broke seems to have
fixed it, Thanks Dan!

/Joe

Daniel Fischer wrote:

> Am Montag, 2. März 2009 05:24 schrieb Joseph Fredette:
>  
>> I'm attempting to install hint, I started by doing:
>>
>> cabal install hint
>>
>> and it gives me the following error:
>>
>> cabal: dependencies conflict: ghc-6.10.1 requires process ==1.0.1.1 however
>> process-1.0.1.1 was excluded because ghc-6.10.1 requires process ==1.0.1.0
>>
>>    
>
> That seems to be *the* most frequent problem this year.
>
> Duncan Coutts explained the matter in
> http://haskell.org/pipermail/haskell-cafe/2009-January/054523.html
>
> Hopefully one of the process packages is in the user db, if both are in the
> global db, it might be necessary to reinstall ghc.
>
>  
>> So I decided to try installing it via darcs, expecting to either have it
>> work, or boil it down to one or two dependencies that were causing the
>> problem, my hunch was right, it boils down to the ghc-mtl package,
>> leading to the same error as above. My question is, how can I fix this?
>> Doing a ghc-pkg hide on either process package breaks Cabal and Haddock
>> (among others) according to the error message, and even after that
>> happens, cabal complains about needing ghc >= 6.6 (or 6.8, depending on
>> which package I disable), even though I have ghc 6.10.
>>
>> Detailed system info follows, help me haskell-cafe-kenobi(s), you're
>> (all) my only hope(s)!
>>
>> Sysinfo:
>>
>> Arch Linux: uname -a gives:
>> Linux Erdos 2.6.28-ARCH #1 SMP PREEMPT Mon Feb 2 22:22:59 UTC 2009 i686
>> Intel(R) Celeron(R) CPU 3.06GHz GenuineIntel GNU/Linux
>>
>> ghc --version gives:
>> The Glorious Glasgow Haskell Compilation System, version 6.10.1
>>
>> cabal --version:
>> cabal-install version 0.6.0
>> using version 1.6.0.1 of the Cabal library
>>
>> Thanks again,
>>
>> /Joe
>>    
>
>
>  

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe

jfredett.vcf (308 bytes) Download Attachment