How to determine minimal dependency of package

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

How to determine minimal dependency of package

yi huang
I'm writing my first haskell package, how do i determine the minimal dependency of it, for example, it use Data.Data, how do i know which version of base package  first introduce Data.Data module, i can't find the answer with google.

--
http://www.yi-programmer.com/blog/

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: How to determine minimal dependency of package

Anthony Cowley
On Fri, Jul 15, 2011 at 10:48 AM, yi huang <[hidden email]> wrote:
> I'm writing my first haskell package, how do i determine the minimal
> dependency of it, for example, it use Data.Data, how do i know which version
> of base package  first introduce Data.Data module, i can't find the answer
> with google.

You should specify the minimum version you have tested with.

Anthony

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: How to determine minimal dependency of package

Daniel Patterson
Based on the package versioning policy [1], A.B is a major version, so if you know that it works with 1.2, then it is reasonably safe to specify the range >= 1.2 && <1.3, as no major api breaking changes should occur within the 1.2 range (ie, 1.2.1 to 1.2.2, etc)

1. http://www.haskell.org/haskellwiki/Package_versioning_policy#Version_numbers

On Jul 15, 2011, at 10:56 AM, Anthony Cowley wrote:

On Fri, Jul 15, 2011 at 10:48 AM, yi huang <[hidden email]> wrote:
I'm writing my first haskell package, how do i determine the minimal
dependency of it, for example, it use Data.Data, how do i know which version
of base package  first introduce Data.Data module, i can't find the answer
with google.

You should specify the minimum version you have tested with.

Anthony

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: How to determine minimal dependency of package

Ivan Lazar Miljenovic
On 16 July 2011 01:04, Daniel Patterson <[hidden email]> wrote:
> Based on the package versioning policy [1], A.B is a major version, so if
> you know that it works with 1.2, then it is reasonably safe to specify the
> range >= 1.2 && <1.3, as no major api breaking changes should occur within
> the 1.2 range (ie, 1.2.1 to 1.2.2, etc)
> 1. http://www.haskell.org/haskellwiki/Package_versioning_policy#Version_numbers

Not quite: if you're using version x.y.z then it may have an
additional function, etc. that was added compared to just x.y ; as
such the bounds are >= x.y.z && < x.(y+1)

That said, very few packages seem to have versions where they add
something without removing or modifying something else, so in most
cases you are correct.

--
Ivan Lazar Miljenovic
[hidden email]
IvanMiljenovic.wordpress.com

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe