Install Yi editor with GHC 6.10.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Install Yi editor with GHC 6.10.1

Andy Stewart-5
Hi all,

I have install GHC 6.10.1 and Gtk2hs (darcs version) in Debian.
So i want to ask, have anyone install Yi (darcs version) with GHC 6.10.1
successfully?

And the best way to install darcs version Yi?

Thank you very much!

  -- Andy

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Install Yi editor with GHC 6.10.1

Austin Seipp
Excerpts from lazycat.manatee's message of Tue Dec 02 23:18:50 -0600 2008:
> Hi all,
>
> I have install GHC 6.10.1 and Gtk2hs (darcs version) in Debian.
> So i want to ask, have anyone install Yi (darcs version) with GHC 6.10.1
> successfully?

Yes. cabal install is basically the easiest way to do it:

 $ cabal update
 $ cabal install yi

> And the best way to install darcs version Yi?

 $ darcs get http://code.haskell.org/yi yi-darcs
 $ cd yi-darcs
 $ cabal install

You will need darcs v2 (I normally use the yi darcs repo fwiw, jpb
pushes lots of little fixes/optimizations regularly. Recently in yi
0.5.2 and the darcs version some major memory leaks have been fixed it
seems.)

Austin
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Install Yi editor with GHC 6.10.1

Andy Stewart-5
Hi Austin,

Austin Seipp <[hidden email]> writes:

> Excerpts from lazycat.manatee's message of Tue Dec 02 23:18:50 -0600 2008:
>> Hi all,
>>
>> I have install GHC 6.10.1 and Gtk2hs (darcs version) in Debian.
>> So i want to ask, have anyone install Yi (darcs version) with GHC 6.10.1
>> successfully?
>
> Yes. cabal install is basically the easiest way to do it:
>
>  $ cabal update
>  $ cabal install yi
>
>> And the best way to install darcs version Yi?
>
>  $ darcs get http://code.haskell.org/yi yi-darcs
>  $ cd yi-darcs
>  $ cabal install
>
> You will need darcs v2 (I normally use the yi darcs repo fwiw, jpb
> pushes lots of little fixes/optimizations regularly. Recently in yi
> 0.5.2 and the darcs version some major memory leaks have been fixed it
> seems.)
>
> Austin

Thank you.

But i have install Yi 0.5.2 and 0.5.3 and got same error:

,----
| ....
|
| [ 78 of 105] Compiling Yi.Core          ( Yi/Core.hs, dist/build/Yi/Core.o )
| [ 79 of 105] Compiling Yi.File          ( Yi/File.hs, dist/build/Yi/File.o )
| [ 80 of 105] Compiling Yi.MiniBuffer    ( Yi/MiniBuffer.hs, dist/build/Yi/MiniBuffer.o )
| [ 81 of 105] Compiling Yi.Dired         ( Yi/Dired.hs, dist/build/Yi/Dired.o )
| [ 82 of 105] Compiling Yi.Eval          ( Yi/Eval.hs, dist/build/Yi/Eval.o )
| [ 83 of 105] Compiling Yi.Mode.Compilation ( Yi/Mode/Compilation.hs, dist/build/Yi/Mode/Compilation.o )
| [ 84 of 105] Compiling Yi.Mode.Interactive ( Yi/Mode/Interactive.hs, dist/build/Yi/Mode/Interactive.o )
| [ 85 of 105] Compiling Yi.Mode.Haskell  ( Yi/Mode/Haskell.hs, dist/build/Yi/Mode/Haskell.o )
| [ 86 of 105] Compiling Yi.Search        ( Yi/Search.hs, dist/build/Yi/Search.o )
| [ 87 of 105] Compiling Yi.TextCompletion ( Yi/TextCompletion.hs, dist/build/Yi/TextCompletion.o )
| [ 88 of 105] Compiling Yi.UI.Gtk.ProjectTree ( Yi/UI/Gtk/ProjectTree.hs, dist/build/Yi/UI/Gtk/ProjectTree.o )
|
| Yi/UI/Gtk/ProjectTree.hs:19:40:
|     Module `Graphics.UI.Gtk' does not export `Event'
| cabal: Error: some packages failed to install:
| yi-0.5.2 failed during the building phase. The exception was:
| exit: ExitFailure 1
`----

Any help?

  -- Andy

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe