Installing hsdev on windows

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing hsdev on windows

Yotam Ohad
Hi cafe,

I installed haskell platform for windows 10 and then ran `cabal install hsdev`
I got the following error:

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: hsdev-0.3.1.4 (user goal)
[__1] trying: hlint-2.1.10 (dependency of hsdev)
[__2] trying: haskell-src-exts-1.20.2 (dependency of hsdev)
[__3] next goal: ghc-syb-utils (dependency of hsdev)
[__3] rejecting: ghc-syb-utils-0.3.0.0 (conflict: hsdev =>
ghc-syb-utils>=0.2.3 && <0.3)
[__3] trying: ghc-syb-utils-0.2.3.3
[__4] next goal: ghc (dependency of hsdev)
[__4] rejecting: ghc-8.4.3/installed-8.4..., ghc-8.4.3, ghc-8.4.1 (conflict:
ghc-syb-utils => ghc>=7.0 && <8.4)
[__4] rejecting: ghc-8.2.2, ghc-8.2.1 (conflict: hsdev => ghc==8.4.*)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: hsdev, haskell-src-exts, ghc-mod,
hlint, base, ghc, ghc-syb-utils

Any Ideas on how to solve this? I'm clueless

thanks

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.
Reply | Threaded
Open this post in threaded view
|

Re: Installing hsdev on windows

Phyx
Hi, 

It seems to be saying that the package is incompatible with ghc 8.4. You can try 'cabal install hsdev --allow-newer' but this probably well result in a compile error if the package depends on ghc api. 

If it does then you need an older platform. 

Kind regards, 
Tamar 

On Fri, Aug 31, 2018, 17:48 Yotam Ohad <[hidden email]> wrote:
Hi cafe,

I installed haskell platform for windows 10 and then ran `cabal install hsdev`
I got the following error:

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: hsdev-0.3.1.4 (user goal)
[__1] trying: hlint-2.1.10 (dependency of hsdev)
[__2] trying: haskell-src-exts-1.20.2 (dependency of hsdev)
[__3] next goal: ghc-syb-utils (dependency of hsdev)
[__3] rejecting: ghc-syb-utils-0.3.0.0 (conflict: hsdev =>
ghc-syb-utils>=0.2.3 && <0.3)
[__3] trying: ghc-syb-utils-0.2.3.3
[__4] next goal: ghc (dependency of hsdev)
[__4] rejecting: ghc-8.4.3/installed-8.4..., ghc-8.4.3, ghc-8.4.1 (conflict:
ghc-syb-utils => ghc>=7.0 && <8.4)
[__4] rejecting: ghc-8.2.2, ghc-8.2.1 (conflict: hsdev => ghc==8.4.*)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: hsdev, haskell-src-exts, ghc-mod,
hlint, base, ghc, ghc-syb-utils

Any Ideas on how to solve this? I'm clueless

thanks
_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.
Reply | Threaded
Open this post in threaded view
|

Re: Installing hsdev on windows

Alexis King
In reply to this post by Yotam Ohad
To add to this, note that the error message is claiming that hsdev is
fine with ghc 8.4 (which is what it means when it says “hsdev =>
ghc==8.4.*”), but one of its dependencies, in this case ghc-syb-utils,
is not. However, if you look at ghc-syb-utils on Hackage[1], you’ll see
that there is a newer version, 0.3.0.0, that supports ghc 8.4 but is
excluded from the search because hsdev declares an upper bound on
ghc-syb-utils.

I haven’t looked into whether or not hsdev is likely compatible with
ghc-syb-utils 0.3.0.0, since ghc-syb-utils does not provide a changelog,
but either way, hsdev needs to be updated (either via Hackage revision
or code change) to allow the solver to use ghc-syb-utils 0.3.0.0. This
would resolve the immediate problem, though it is of course possible
that there would still be incompatibilities with other packages after
the solver is able to progress past this point.

As an aside, Hackage Matrix CI for hsdev[2] indicates that valid install
plans can be constructed for GHC 8.0 and 8.2, so if you really want/need
to install hsdev, you could get away with using an earlier version of
GHC until hsdev and its dependencies are updated.

Alexis

[1]: https://hackage.haskell.org/package/ghc-syb-utils
[2]: https://matrix.hackage.haskell.org/package/hsdev

> On Aug 31, 2018, at 10:47, Yotam Ohad <[hidden email]> wrote:
>
> Hi cafe,
>
> I installed haskell platform for windows 10 and then ran `cabal install hsdev`
> I got the following error:
>
> Resolving dependencies...
> cabal: Could not resolve dependencies:
> [__0] trying: hsdev-0.3.1.4 (user goal)
> [__1] trying: hlint-2.1.10 (dependency of hsdev)
> [__2] trying: haskell-src-exts-1.20.2 (dependency of hsdev)
> [__3] next goal: ghc-syb-utils (dependency of hsdev)
> [__3] rejecting: ghc-syb-utils-0.3.0.0 (conflict: hsdev =>
> ghc-syb-utils>=0.2.3 && <0.3)
> [__3] trying: ghc-syb-utils-0.2.3.3
> [__4] next goal: ghc (dependency of hsdev)
> [__4] rejecting: ghc-8.4.3/installed-8.4..., ghc-8.4.3, ghc-8.4.1 (conflict:
> ghc-syb-utils => ghc>=7.0 && <8.4)
> [__4] rejecting: ghc-8.2.2, ghc-8.2.1 (conflict: hsdev => ghc==8.4.*)
> After searching the rest of the dependency tree exhaustively, these were the
> goals I've had most trouble fulfilling: hsdev, haskell-src-exts, ghc-mod,
> hlint, base, ghc, ghc-syb-utils
>
> Any Ideas on how to solve this? I'm clueless
>
> thanks

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.