Issue 362 in xmonad: disabling focus following mouse doesn't work

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue 362 in xmonad: disabling focus following mouse doesn't work

codesite-noreply@google.com
Status: New
Owner: ----

New issue 362 by zl29ah: disabling focus following mouse doesn't work
http://code.google.com/p/xmonad/issues/detail?id=362

What steps will reproduce the problem?
0. Disable focus following mouse
1. Switch to another workspace
2. Shuffle mouse around
3. Enjoy seeing it focusing windows while not updating the frames' colors
4. After switching the focus using keyboard or mouse click everything  
become ok

What version of the product are you using? On what operating system?
0.9.1 on gentoo linux

Are you using an xmonad.hs?  Please attach it and the output of "xmonad
--recompile".
l29ah@l29ah-work ~/.xmonad $ xmonad --recompile
l29ah@l29ah-work ~/.xmonad $


Attachments:
        xmonad.hs  11.2 KB

--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings
Reply | Threaded
Open this post in threaded view
|

Re: Issue 362 in xmonad: disabling focus following mouse doesn't work

codesite-noreply@google.com

Comment #1 on issue 362 by zl29ah: disabling focus following mouse doesn't  
work
http://code.google.com/p/xmonad/issues/detail?id=362

looks like the attached patch fixes the problem
thanks flies out to [hidden email]

Attachments:
        xmonad-focus-follows-mouse-fix.patch  602 bytes

--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings
Reply | Threaded
Open this post in threaded view
|

Re: Issue 362 in xmonad: disabling focus following mouse doesn't work

codesite-noreply@google.com

Comment #2 on issue 362 by zl29ah: disabling focus following mouse doesn't  
work
http://code.google.com/p/xmonad/issues/detail?id=362

The bug seems to be actual on the current darcs version. The patch doesn't  
solve the problem.

Reply | Threaded
Open this post in threaded view
|

Issue 362 in xmonad: disabling focus following mouse doesn't work

codesite-noreply@google.com
Updates:
        Status: Fixed

Comment #3 on issue 362 by wirtwo... at gmail.com: disabling focus following  
mouse doesn't work
http://code.google.com/p/xmonad/issues/detail?id=362

Cannot reproduce with current darcs xmonad/contrib. Please feel free to  
re-open if needed.



Reply | Threaded
Open this post in threaded view
|

Issue 362 in xmonad: disabling focus following mouse doesn't work

codesite-noreply@google.com

Comment #4 on issue 362 by zl2... at gmail.com: disabling focus following  
mouse doesn't work
http://code.google.com/p/xmonad/issues/detail?id=362

Okay, finally found a way to reproduce: put the mouse pointer to a corner  
of the screen, then switch to another workspace. Focus will follow the  
mouse without updating the border colors.



Reply | Threaded
Open this post in threaded view
|

Re: Issue 362 in xmonad: disabling focus following mouse doesn't work

codesite-noreply@google.com

Comment #5 on issue 362 by [hidden email]: disabling focus following  
mouse doesn't work
https://code.google.com/p/xmonad/issues/detail?id=362

Hello? Still broken in darcs, can't reopen the bug, reproduceable by  
putting the mouse pointer to the upper left corner.

--
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings
_______________________________________________
xmonad mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/xmonad
Reply | Threaded
Open this post in threaded view
|

Re: Issue 362 in xmonad: disabling focus following mouse doesn't work

codesite-noreply@google.com
Updates:
        Status: New

Comment #6 on issue 362 by [hidden email]: disabling focus following  
mouse doesn't work
https://code.google.com/p/xmonad/issues/detail?id=362

(No comment was entered for this change.)

--
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings
_______________________________________________
xmonad mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/xmonad