Issue 600 in xmonad: conflicting install instructions

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue 600 in xmonad: conflicting install instructions

codesite-noreply@google.com
Status: New
Owner: ----

New issue 600 by Ian... at gmail.com: conflicting install instructions
https://code.google.com/p/xmonad/issues/detail?id=600

What steps will reproduce the problem?
1. http://xmonad.org
2. follow link to http://xmonad.org/download.html
3. read: cabal install http://code.haskell.org/xmonad/xmonad.tar.gz
4. follow link to http://xmonad.org/intro.html
5. read conflicting instruction: cabal install xmonad

Let's at least have a consistently documented and supported way to build,  
especially since building xmonad is quite prone to being broken in  
different circumstances.

--
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

Reply | Threaded
Open this post in threaded view
|

Issue 600 in xmonad: conflicting install instructions

codesite-noreply@google.com

Comment #1 on issue 600 by vogt.a... at gmail.com: conflicting install  
instructions
https://code.google.com/p/xmonad/issues/detail?id=600

All three options presented on download.html are supposed to work:

- distro pkg
- hackage
- darcs get / tar.gz snapshot

"cabal install http://code.haskell.org/xmonad/xmonad.tar.gz" is just there  
for people that have trouble installing darcs (such as archlinux  
currently), but for whatever reason would like to run the development  
version.

We can remove "cabal install http://code.haskell.org/xmonad/xmonad.tar.gz"  
(PR https://github.com/davidlazar/xmonad.org), but that still leaves people  
the choice between using a release or using the bleeding edge.



--
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

Reply | Threaded
Open this post in threaded view
|

Issue 600 in xmonad: conflicting install instructions

codesite-noreply@google.com

Comment #2 on issue 600 by Ian... at gmail.com: conflicting install  
instructions
https://code.google.com/p/xmonad/issues/detail?id=600

Having different ways of installing is great. There is just a little  
confusing inconsistency going on. And I actually wasn't super clear in my  
bug.

Let me clarify. Background: http://xmonad.org/download.html is where users  
are funneled from the main page, it appears to overview the install  
methods, and leads users on to  http://xmonad.org/intro.html which appears  
to be the complete documentation on install.

1. download.html says "After you've downloaded, follow the install  
instructions (link to intro.html)", then on intro.html, the tarbal you  
downloaded is never mentioned. So either remove the mention of downloading  
manually from hackage, or have an  instruction which involves  
xmonad-<version>.tar.gz on intro.html. I still don't know how you would  
install the tarball. cabal install xmonad-<version>.tar.gz? The download  
link on hackage is not the easiest to find (at the bottom of the page), so  
I'd prefer steering people to the simpler cabal install <name> method.

2. intro.html should mention the "cabal install  
http://code.haskell.org/xmonad/xmonad.tar.gz" method which was first  
mentioned on the download.html page or else it's confusing (this first page  
said I could do this, and now this other page looks like it's meant to  
cover everything, but it doesn't say I can do this).

If this makes sense, I can write a patch and do a PR on github.

--
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

Reply | Threaded
Open this post in threaded view
|

Re: Issue 600 in xmonad: conflicting install instructions

codesite-noreply@google.com

Comment #3 on issue 600 by [hidden email]: conflicting install  
instructions
https://code.google.com/p/xmonad/issues/detail?id=600

I would say go ahead and make a pull request. Personally I think it makes  
more sense to add information to both pages as appropriate to make them  
consistent than it does to remove information from either.

--
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings
_______________________________________________
xmonad mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/xmonad
Reply | Threaded
Open this post in threaded view
|

Re: Issue 600 in xmonad: conflicting install instructions

codesite-noreply@google.com

Comment #4 on issue 600 by [hidden email]: conflicting install  
instructions
https://code.google.com/p/xmonad/issues/detail?id=600

Wait, pull requests? github? The last I knew xmonad uses darcs and is not  
hosted on github.  Did I miss something?

I do agree that adding some information to the pages makes sense.

--
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings
_______________________________________________
xmonad mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/xmonad