Need help: Cabal rejecting stringsearch, conflict in base

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Need help: Cabal rejecting stringsearch, conflict in base

Thiago Negri
I don't know what to do. :-(
I can't install scotty or yesod.

$ cabal install scotty
cabal: Could not resolve dependencies:
trying: scotty-0.5.0 (user goal)
trying: base-4.7.0.0/installed-dc1... (dependency of scotty-0.5.0)
trying: wai-extra-1.3.4.6 (dependency of scotty-0.5.0)
trying: stringsearch-0.3.6.4 (dependency of wai-extra-1.3.4.6)
rejecting: stringsearch-0.3.6.4:-base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=2 && <3)
rejecting: stringsearch-0.3.6.4:+base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=3 && <4)
Backjump limit reached (change with --max-backjumps).


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Need help: Cabal rejecting stringsearch, conflict in base

Clark Gaebel-2
You've got two options:

1) (the easy way)

rm -rf ~/.ghc ~/.cabal
cabal update
cabal install scotty

2) (the hard way, ghc 7.6+ only)

Use a sandbox!

cd path/to/my/project/that/uses/scotty
cabal sandbox init
cabal install --only-dependencies -j # make sure scotty is a dependency of your project
cabal configure
cabal build

3) use cabal-dev. similar to using sandboxes, but I don't have it any more so can't give you a step-by-step.


On Tue, Nov 26, 2013 at 7:34 PM, Thiago Negri <[hidden email]> wrote:
I don't know what to do. :-(
I can't install scotty or yesod.

$ cabal install scotty
cabal: Could not resolve dependencies:
trying: scotty-0.5.0 (user goal)
trying: base-4.7.0.0/installed-dc1... (dependency of scotty-0.5.0)
trying: wai-extra-1.3.4.6 (dependency of scotty-0.5.0)
trying: stringsearch-0.3.6.4 (dependency of wai-extra-1.3.4.6)
rejecting: stringsearch-0.3.6.4:-base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=2 && <3)
rejecting: stringsearch-0.3.6.4:+base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=3 && <4)
Backjump limit reached (change with --max-backjumps).


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe




--
Clark.

Key ID     : 0x78099922
Fingerprint: B292 493C 51AE F3AB D016  DD04 E5E3 C36F 5534 F907

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Need help: Cabal rejecting stringsearch, conflict in base

Schell Scivally
It looks like you're using ghc7.7 (soon 7.8) since you're on base-4.7. A lot of packages just aren't ready for ghc7.7. Either they need bumps to their dependencies or they need Typeable updates or...or...

If you want to live in the future I'd suggest following the packages in question to their git repos, cloning them and using those (and possibly patching them). I've been doing as much of this as I can and it's been working!

Though I may be misunderstanding your problem and in that case - ignore me! :) 


On Tue, Nov 26, 2013 at 4:41 PM, Clark Gaebel <[hidden email]> wrote:
You've got two options:

1) (the easy way)

rm -rf ~/.ghc ~/.cabal
cabal update
cabal install scotty

2) (the hard way, ghc 7.6+ only)

Use a sandbox!

cd path/to/my/project/that/uses/scotty
cabal sandbox init
cabal install --only-dependencies -j # make sure scotty is a dependency of your project
cabal configure
cabal build

3) use cabal-dev. similar to using sandboxes, but I don't have it any more so can't give you a step-by-step.


On Tue, Nov 26, 2013 at 7:34 PM, Thiago Negri <[hidden email]> wrote:
I don't know what to do. :-(
I can't install scotty or yesod.

$ cabal install scotty
cabal: Could not resolve dependencies:
trying: scotty-0.5.0 (user goal)
trying: base-4.7.0.0/installed-dc1... (dependency of scotty-0.5.0)
trying: wai-extra-1.3.4.6 (dependency of scotty-0.5.0)
trying: stringsearch-0.3.6.4 (dependency of wai-extra-1.3.4.6)
rejecting: stringsearch-0.3.6.4:-base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=2 && <3)
rejecting: stringsearch-0.3.6.4:+base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=3 && <4)
Backjump limit reached (change with --max-backjumps).


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe




--
Clark.

Key ID     : 0x78099922
Fingerprint: B292 493C 51AE F3AB D016  DD04 E5E3 C36F 5534 F907

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe




--
Schell Scivally
http://blog.efnx.com
http://github.com/schell
http://twitter.com/schellsan

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Need help: Cabal rejecting stringsearch, conflict in base

Daniel Fischer
In reply to this post by Thiago Negri
On Tuesday 26 November 2013, 22:34:49, Thiago Negri wrote:

> I don't know what to do. :-(
> I can't install scotty or yesod.
>
> $ cabal install scotty
> cabal: Could not resolve dependencies:
> trying: scotty-0.5.0 (user goal)
> trying: base-4.7.0.0/installed-dc1... (dependency of scotty-0.5.0)
> trying: wai-extra-1.3.4.6 (dependency of scotty-0.5.0)
> trying: stringsearch-0.3.6.4 (dependency of wai-extra-1.3.4.6)
> rejecting: stringsearch-0.3.6.4:-base3 (conflict:
> base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=2 && <3)
> rejecting: stringsearch-0.3.6.4:+base3 (conflict:
> base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=3 && <4)
> Backjump limit reached (change with --max-backjumps).

I've just uploaded 0.3.6.5 that allows array-0.5, which probably was the
problem. Hopefully it will work now.
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Need help: Cabal rejecting stringsearch, conflict in base

Thiago Negri
In reply to this post by Clark Gaebel-2
I did the easy way and it worked!
The bad thing is that after restarting my laptop, xmonad and xmobar were gone.
I recompiled xmonad and it's ok, but xmobar is failing to build because "unix" package is failing because "Signals.h" is missing (used by System.Posix.Signals).
:-(

I guess my cabal environment is messed up.
Is `rm -rf ~/.ghc ~/.cabal` supposed to reset cabal installation?
How do I start a fresh cabal environment?




2013/11/26 Clark Gaebel <[hidden email]>
You've got two options:

1) (the easy way)

rm -rf ~/.ghc ~/.cabal
cabal update
cabal install scotty

2) (the hard way, ghc 7.6+ only)

Use a sandbox!

cd path/to/my/project/that/uses/scotty
cabal sandbox init
cabal install --only-dependencies -j # make sure scotty is a dependency of your project
cabal configure
cabal build

3) use cabal-dev. similar to using sandboxes, but I don't have it any more so can't give you a step-by-step.


On Tue, Nov 26, 2013 at 7:34 PM, Thiago Negri <[hidden email]> wrote:
I don't know what to do. :-(
I can't install scotty or yesod.

$ cabal install scotty
cabal: Could not resolve dependencies:
trying: scotty-0.5.0 (user goal)
trying: base-4.7.0.0/installed-dc1... (dependency of scotty-0.5.0)
trying: wai-extra-1.3.4.6 (dependency of scotty-0.5.0)
trying: stringsearch-0.3.6.4 (dependency of wai-extra-1.3.4.6)
rejecting: stringsearch-0.3.6.4:-base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=2 && <3)
rejecting: stringsearch-0.3.6.4:+base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=3 && <4)
Backjump limit reached (change with --max-backjumps).


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe




--
Clark.

Key ID     : 0x78099922
Fingerprint: B292 493C 51AE F3AB D016  DD04 E5E3 C36F 5534 F907


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Need help: Cabal rejecting stringsearch, conflict in base

Carter Schonwald
Just remove the .ghc. No need to touch .cabal. 

On Friday, November 29, 2013, Thiago Negri wrote:
I did the easy way and it worked!
The bad thing is that after restarting my laptop, xmonad and xmobar were gone.
I recompiled xmonad and it's ok, but xmobar is failing to build because "unix" package is failing because "Signals.h" is missing (used by System.Posix.Signals).
:-(

I guess my cabal environment is messed up.
Is `rm -rf ~/.ghc ~/.cabal` supposed to reset cabal installation?
How do I start a fresh cabal environment?




2013/11/26 Clark Gaebel <<a href="javascript:_e({}, &#39;cvml&#39;, &#39;cgaebel@uwaterloo.ca&#39;);" target="_blank">cgaebel@...>
You've got two options:

1) (the easy way)

rm -rf ~/.ghc ~/.cabal
cabal update
cabal install scotty

2) (the hard way, ghc 7.6+ only)

Use a sandbox!

cd path/to/my/project/that/uses/scotty
cabal sandbox init
cabal install --only-dependencies -j # make sure scotty is a dependency of your project
cabal configure
cabal build

3) use cabal-dev. similar to using sandboxes, but I don't have it any more so can't give you a step-by-step.


On Tue, Nov 26, 2013 at 7:34 PM, Thiago Negri <<a href="javascript:_e({}, &#39;cvml&#39;, &#39;evohunz@gmail.com&#39;);" target="_blank">evohunz@...> wrote:
I don't know what to do. :-(
I can't install scotty or yesod.

$ cabal install scotty
cabal: Could not resolve dependencies:
trying: scotty-0.5.0 (user goal)
trying: base-4.7.0.0/installed-dc1... (dependency of scotty-0.5.0)
trying: wai-extra-1.3.4.6 (dependency of scotty-0.5.0)
trying: stringsearch-0.3.6.4 (dependency of wai-extra-1.3.4.6)
rejecting: stringsearch-0.3.6.4:-base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=2 && <3)
rejecting: stringsearch-0.3.6.4:+base3 (conflict:
base==4.7.0.0/installed-dc1..., stringsearch-0.3.6.4:base3 => base>=3 && <4)
Backjump limit reached (change with --max-backjumps).


_______________________________________________
Haskell-Cafe mailing list
<a href="javascript:_e({}, &#39;cvml&#39;, &#39;Haskell-Cafe@haskell.org&#39;);" target="_blank">Haskell-Cafe@...
http://www.haskell.org/mailman/listinfo/haskell-cafe




--
Clark.

Key ID     : 0x78099922
Fingerprint: B292 493C 51AE F3AB D016  DD04 E5E3 C36F 5534 F907


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: Need help: Cabal rejecting stringsearch, conflict in base

Albert Y. C. Lai
In reply to this post by Thiago Negri
On 13-11-29 06:36 PM, Thiago Negri wrote:
> Is `rm -rf ~/.ghc ~/.cabal` supposed to reset cabal installation?
> How do I start a fresh cabal environment?

Perhaps it is time to read my
http://www.vex.net/~trebla/haskell/sicp.xhtml

> I recompiled xmonad and it's ok, but xmobar is failing to build because
> "unix" package is failing because "Signals.h" is missing (used by
> System.Posix.Signals).

The "unix" package comes with GHC. It is not supposed to be missing, and
not supposed to be rebuilt a la carte. You may have damaged your GHC
installation, or you may have completely misattributed the problem.
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe