Please test: release candidates for Cabal/cabal-install patch releases on the 1.18 and 1.20 branches

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Please test: release candidates for Cabal/cabal-install patch releases on the 1.18 and 1.20 branches

Johan Tibell-2
I've uploaded release candidates for Cabal/cabal-install patch releases on
the 1.18 and 1.20 branches:

https://www.haskell.org/cabal/release/cabal-1.18.1.5/Cabal-1.18.1.5.tar.gz
https://www.haskell.org/cabal/release/cabal-install-1.18.0.6/cabal-install-1.18.0.6.tar.gz

https://www.haskell.org/cabal/release/cabal-1.20.0.3/Cabal-1.20.0.3.tar.gz
https://www.haskell.org/cabal/release/cabal-install-1.20.0.4/cabal-install-1.20.0.4.tar.gz

Please test, especially if one of your fixes are in this release. You can
install both both lib and exe using: cabal install <Cabal URL>
<cabal-install URL>

Changelogs:

Cabal-1.18.1.5:
e4660ff17f923e999080e21a20062d0df8d24bb6 The download dir on haskell.org
moved
fb3db6313b43632fdc9d598140b3eb5a681eb90b Bump Cabal version number to
1.18.1.5
12a698b6db8a2ca55367c54611a269048f4cef7b Build C sources with -fPIC when
GHC is using dynamic libraries.

cabal-install-1.18.0.6:
79ccaa85bba7957344fb1dca06d84220eff9b73c Bump cabal-install version number
to 1.18.0.6
97dc39636bd547782647cb792ceca6c60a7e5ab1 Merge branch '1.18' of
https://github.com/snoyberg/cabal into 1.18
4fbb20f52c842a7c7c173555ff7f0c8b5b67dfa1 Support for network-2.6
6f74da062e6d1bdc6db51acd55d0e2676fa56bf2 SavedConfig Monoid instance: make
list fields work like Flags.
7380144203a233f81ff67052fc3256cf47b9b71f cabal update: use sandbox config
file #1884

Cabal-1.20.0.3
7d7f560cc84dfe643d916efbab7c382b1df5a9e2 Bump cabal-install version number
to 1.20.0.4
813ce2fc23da81b7bf07418a28258a962c44713e Bump Cabal version number to
1.20.0.3
cee305209129480f28190ee7026076962ba9ca97 The download dir on haskell.org
moved
b172747adec9ec8d57d8215e9d1cabb448aa6036 Build C sources with -fPIC when
GHC is using dynamic libraries.
93aba465d35d03b29b1d9bd3a456815272a38a41 Revert
97c6a72984931f4ccf628736024d3459a033af6c.
343257e96fab526da27d143b653433f45c6c1401 s/2.15/2.14.4/

cabal-install-1.20.0.4
7d7f560cc84dfe643d916efbab7c382b1df5a9e2 Bump cabal-install version number
to 1.20.0.4
caf257cd96e766b293943bbac07d766ec2f552dd Self-constraint not included in
frozen constraints
b19175519de6fc40683527c1104ce2a513a03612 Merge branch '1.20' of
https://github.com/snoyberg/cabal into 1.20
1c0d8aafbe42921baa56fc36383f34763f69d327 Revert "Remove redundant network
constraint"
58517f76cb2ccb33c007da596ede265f1192d3b8 Remove redundant network constraint
a747778c25bd339fed9c9a7c77eb3adbf0f162e0 Support for network-2.6
5fcf3d994e5c5a0f101ac04e092a8beedadcdc8d SavedConfig Monoid instance: make
list fields work like Flags.
13f9051d34463037569becf6d3f736a8d8a4570e cabal update: use sandbox config
file #1884
93aba465d35d03b29b1d9bd3a456815272a38a41 Revert
97c6a72984931f4ccf628736024d3459a033af6c.
aa0a6979f3223387aae830cf1d21b2c21978d767 Read installed package info file
as UTF-8
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/ghc-devs/attachments/20141212/e9501134/attachment-0001.html>

Reply | Threaded
Open this post in threaded view
|

Please test: release candidates for Cabal/cabal-install patch releases on the 1.18 and 1.20 branches

Johan Tibell-2
Apparently this no longer works:

cabal install
http://www.haskell.org/cabal/release/cabal-1.20.0.3/Cabal-1.20.0.3.tar.gz
http://www.haskell.org/cabal/release/cabal-install-1.20.0.4/cabal-install-1.20.0.4.tar.gz

Some change on the web server side means that the web server tries to
redirect to an https page, even though cabal-install doesn't support it.

On Fri, Dec 12, 2014 at 2:22 AM, Johan Tibell <johan.tibell at gmail.com>
wrote:

> I've uploaded release candidates for Cabal/cabal-install patch releases on
> the 1.18 and 1.20 branches:
>
> https://www.haskell.org/cabal/release/cabal-1.18.1.5/Cabal-1.18.1.5.tar.gz
>
> https://www.haskell.org/cabal/release/cabal-install-1.18.0.6/cabal-install-1.18.0.6.tar.gz
>
> https://www.haskell.org/cabal/release/cabal-1.20.0.3/Cabal-1.20.0.3.tar.gz
>
> https://www.haskell.org/cabal/release/cabal-install-1.20.0.4/cabal-install-1.20.0.4.tar.gz
>
> Please test, especially if one of your fixes are in this release. You can
> install both both lib and exe using: cabal install <Cabal URL>
> <cabal-install URL>
>
> Changelogs:
>
> Cabal-1.18.1.5:
> e4660ff17f923e999080e21a20062d0df8d24bb6 The download dir on haskell.org
> moved
> fb3db6313b43632fdc9d598140b3eb5a681eb90b Bump Cabal version number to
> 1.18.1.5
> 12a698b6db8a2ca55367c54611a269048f4cef7b Build C sources with -fPIC when
> GHC is using dynamic libraries.
>
> cabal-install-1.18.0.6:
> 79ccaa85bba7957344fb1dca06d84220eff9b73c Bump cabal-install version number
> to 1.18.0.6
> 97dc39636bd547782647cb792ceca6c60a7e5ab1 Merge branch '1.18' of
> https://github.com/snoyberg/cabal into 1.18
> 4fbb20f52c842a7c7c173555ff7f0c8b5b67dfa1 Support for network-2.6
> 6f74da062e6d1bdc6db51acd55d0e2676fa56bf2 SavedConfig Monoid instance: make
> list fields work like Flags.
> 7380144203a233f81ff67052fc3256cf47b9b71f cabal update: use sandbox config
> file #1884
>
> Cabal-1.20.0.3
> 7d7f560cc84dfe643d916efbab7c382b1df5a9e2 Bump cabal-install version number
> to 1.20.0.4
> 813ce2fc23da81b7bf07418a28258a962c44713e Bump Cabal version number to
> 1.20.0.3
> cee305209129480f28190ee7026076962ba9ca97 The download dir on haskell.org
> moved
> b172747adec9ec8d57d8215e9d1cabb448aa6036 Build C sources with -fPIC when
> GHC is using dynamic libraries.
> 93aba465d35d03b29b1d9bd3a456815272a38a41 Revert
> 97c6a72984931f4ccf628736024d3459a033af6c.
> 343257e96fab526da27d143b653433f45c6c1401 s/2.15/2.14.4/
>
> cabal-install-1.20.0.4
> 7d7f560cc84dfe643d916efbab7c382b1df5a9e2 Bump cabal-install version number
> to 1.20.0.4
> caf257cd96e766b293943bbac07d766ec2f552dd Self-constraint not included in
> frozen constraints
> b19175519de6fc40683527c1104ce2a513a03612 Merge branch '1.20' of
> https://github.com/snoyberg/cabal into 1.20
> 1c0d8aafbe42921baa56fc36383f34763f69d327 Revert "Remove redundant network
> constraint"
> 58517f76cb2ccb33c007da596ede265f1192d3b8 Remove redundant network
> constraint
> a747778c25bd339fed9c9a7c77eb3adbf0f162e0 Support for network-2.6
> 5fcf3d994e5c5a0f101ac04e092a8beedadcdc8d SavedConfig Monoid instance: make
> list fields work like Flags.
> 13f9051d34463037569becf6d3f736a8d8a4570e cabal update: use sandbox config
> file #1884
> 93aba465d35d03b29b1d9bd3a456815272a38a41 Revert
> 97c6a72984931f4ccf628736024d3459a033af6c.
> aa0a6979f3223387aae830cf1d21b2c21978d767 Read installed package info file
> as UTF-8
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/ghc-devs/attachments/20141212/1992e37f/attachment.html>

Reply | Threaded
Open this post in threaded view
|

Please test: release candidates for Cabal/cabal-install patch releases on the 1.18 and 1.20 branches

Johan Tibell-2
In reply to this post by Johan Tibell-2
Ben,

Is this something that worked in cabal-install 1.18.0.5 and that stopped
working in 1.18.0.6 or is it something that didn't work in 1.18.0.5 but you
expected to be fixed in 1.18.0.6? These 1.18 and 1.20 releases just target
a very few critical bugs. They are not attempts to backport all bugfixes
from master.

In 1.18 the critical fixes are:
12a698b6db8a2ca55367c54611a269048f4cef7b Build C sources with -fPIC when
GHC is using dynamic libraries.
4fbb20f52c842a7c7c173555ff7f0c8b5b67dfa1 Support for network-2.6
6f74da062e6d1bdc6db51acd55d0e2676fa56bf2 SavedConfig Monoid instance: make
list fields work like Flags.
7380144203a233f81ff67052fc3256cf47b9b71f cabal update: use sandbox config
file #1884

As for installing, after downloading the two tarballs to a temp dir this
works for me:

cabal install Cabal-1.18.1.5.tar.gz cabal-install-1.18.0.6.tar.gz

-- Johan

On Fri, Dec 12, 2014 at 4:52 AM, Ben Gamari <bgamari.foss at gmail.com> wrote:

>
> Johan Tibell <johan.tibell at gmail.com> writes:
>
> > I've uploaded release candidates for Cabal/cabal-install patch releases
> on
> > the 1.18 and 1.20 branches:
> >
> >
> https://www.haskell.org/cabal/release/cabal-1.18.1.5/Cabal-1.18.1.5.tar.gz
> >
> https://www.haskell.org/cabal/release/cabal-install-1.18.0.6/cabal-install-1.18.0.6.tar.gz
> >
> >
> https://www.haskell.org/cabal/release/cabal-1.20.0.3/Cabal-1.20.0.3.tar.gz
> >
> https://www.haskell.org/cabal/release/cabal-install-1.20.0.4/cabal-install-1.20.0.4.tar.gz
> >
> > Please test, especially if one of your fixes are in this release. You can
> > install both both lib and exe using: cabal install <Cabal URL>
> > <cabal-install URL>
> >
> First I'll look at Cabal-1.18.1.5 and cabal-install-1.18.0.6.
>
> Unfortunately there still seems to be trouble invoking cabal in a tree
> previously used by a previous Cabal version. For instance,
>
>     $ tar -zxf cabal-install-1.18.0.6.tar.gz
>     $ cd cabal-install-1.18.0.6
>     $ cabal install
>     $ cabal install --enable-tests
>     Warning: The package list for 'hackage.haskell.org' is 71 days old.
>     Run 'cabal update' to get the latest list of available packages.
>     Resolving dependencies...
>     Configuring cabal-install-1.18.0.6...
>     Building cabal-install-1.18.0.6...
>     cabal: dist/package.conf.inplace: inappropriate type
>     Failed to install cabal-install-1.18.0.6
>     cabal: Error: some packages failed to install:
>     cabal-install-1.18.0.6 failed during the building phase. The exception
> was:
>     ExitFailure 1
>
> I have noticed this problem in the past as well. Deleting dist/ resolves
> the issue. I seem to recall some discussion where it was claimed this
> was fixed although I could be wrong.  This was reproducible on x86_64
> (building with GHC 7.8.3 and 7.6.3) and ARM.
>
> After this was resolved I encountered the following,
>
>     $ cabal install --enable-tests
>     ...
>
>     Preprocessing test suite 'unit-tests' for cabal-install-1.18.0.6...
>
>     Distribution/Client/Targets.hs:100:8:
>         Could not find module `Network.URI'
>         It is a member of the hidden package `network-2.4.2.2'.
>         Perhaps you need to add `network' to the build-depends in your
> .cabal file.
>         It is a member of the hidden package `network-uri-2.6.0.1'.
>         Perhaps you need to add `network-uri' to the build-depends in your
> .cabal file.
>         Use -v to see a list of the files searched for.
>     Failed to install cabal-install-1.18.0.6
>     cabal: Error: some packages failed to install:
>
> This is fixed in master. It seems you should probably cherry-pick
> 2826c97d11a495085008c4bddf499fcfd05e0df2 onto the release branch.
>
> After this I was able to run the testsuite. cabal-install was fine;
> Cabal failed with,
>
>     TestSuiteExeV10/TestWithHpc:
>       : [Failed]
>     expected: 'setup build' should succeed
>       output: "/opt/exp/haskell-packages/Cabal-1.18.1.5/tests/Setup
> configure --user -w /opt/exp/ghc/root-ghc-7.8/bin/ghc --enable-tests
> --enable-library-coverage" in PackageTests/TestSuiteExeV10
>     Setup: Option --enable-library-coverage is obsolete! Please use
>     --enable-coverage instead.
>
>     ...
>
>     BuildTestSuiteDetailedV09:
>       : [Failed]
>     build failed!
>     expected: False
>      but got: True
>
> I didn't investigate into the cause of these any further.
>
> I also used the new cabal executable to install Yesod has progressed
> quite (on the ARM, even) far and shows no sign failure.
>
> I'll take a look at the 1.20 releases tomorrow.
>
> Cheers,
>
>  - Ben
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/ghc-devs/attachments/20141212/a4d558db/attachment.html>

Reply | Threaded
Open this post in threaded view
|

Please test: release candidates for Cabal/cabal-install patch releases on the 1.18 and 1.20 branches

Ben Gamari-2
Johan Tibell <johan.tibell at gmail.com> writes:

> Ben,
>
> Is this something that worked in cabal-install 1.18.0.5 and that stopped
> working in 1.18.0.6 or is it something that didn't work in 1.18.0.5 but you
> expected to be fixed in 1.18.0.6? These 1.18 and 1.20 releases just target
> a very few critical bugs. They are not attempts to backport all bugfixes
> from master.
>
Fair enough; ignore the first issue in that case. Nevertheless, given
that the network-2.6 fix made it in I think it would be worth
cherry-picking the network-uri fix as well so that the release can be
properly tested.

Things look pretty good to me otherwise. I'll test 1.20 next.

Cheers,

- Ben
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 472 bytes
Desc: not available
URL: <http://www.haskell.org/pipermail/ghc-devs/attachments/20141212/f66c5164/attachment.sig>

Reply | Threaded
Open this post in threaded view
|

Please test: release candidates for Cabal/cabal-install patch releases on the 1.18 and 1.20 branches

Ben Gamari-2
Ben Gamari <ben at smart-cactus.org> writes:

> Johan Tibell <johan.tibell at gmail.com> writes:
>
>> Ben,
>>
>> Is this something that worked in cabal-install 1.18.0.5 and that stopped
>> working in 1.18.0.6 or is it something that didn't work in 1.18.0.5 but you
>> expected to be fixed in 1.18.0.6? These 1.18 and 1.20 releases just target
>> a very few critical bugs. They are not attempts to backport all bugfixes
>> from master.
>>
> Fair enough; ignore the first issue in that case. Nevertheless, given
> that the network-2.6 fix made it in I think it would be worth
> cherry-picking the network-uri fix as well so that the release can be
> properly tested.
>
> Things look pretty good to me otherwise. I'll test 1.20 next.
>
1.20 looks good to me.

Cheers,

- Ben

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 472 bytes
Desc: not available
URL: <http://www.haskell.org/pipermail/ghc-devs/attachments/20141213/585810b6/attachment.sig>