Problem install ghc 6.10.2

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem install ghc 6.10.2

aditya siram-2
Hi all,
I am trying to install the Linux GHC 6.10.2 binary, but when I fire up ghci
I get the following error:
GHCi, version 6.10.2: http://www.haskell.org/ghc/  :? for help
Glasgow Haskell Compiler, Version 6.10.2, for Haskell 98, stage 2 booted by
GHC version 6.10.1
Using package config file: /usr/local/lib/ghc-6.10.2/./package.conf
wired-in package ghc-prim[""] not found.
wired-in package integer[""] not found.
wired-in package base[""] not found.
wired-in package rts mapped to rts-1.0
wired-in package haskell98[""] not found.
wired-in package syb[""] not found.
wired-in package template-haskell[""] not found.
wired-in package dph-seq[""] not found.
wired-in package dph-par[""] not found.
package haddock-2.4.2 will be ignored due to missing or recursive
dependencies:
  Cabal-1.6.0.3 array-0.2.0.0 base-4.1.0.0 containers-0.2.0.1
directory-1.0.0.3 filepath-1.1.0.2 ghc-6.10.2 haskell98-1.0.1.0
pretty-1.0.1.0
package ghc-6.10.2 will be ignored due to missing or recursive dependencies:
  Cabal-1.6.0.3 array-0.2.0.0 base-4.1.0.0 bytestring-0.9.1.4
containers-0.2.0.1 directory-1.0.0.3 editline-0.2.1.0 filepath-1.1.0.2
haskell98-1.0.1.0 hpc-0.5.0.3 old-time-1.0.0.2 process-1.0.1.1
template-haskell-2.3.0.1 unix-2.3.2.0
Hsc static flags: -static
*** Deleting temp files:
Deleting:
*** Deleting temp dirs:
Deleting:
ghc: panic! (the 'impossible' happened)
  (GHC version 6.10.2 for i386-unknown-linux):
    interactiveUI:setBuffering2

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Running ghc-pkg check gave me :
There are problems in package haddock-2.4.2:
  dependency Cabal-1.6.0.3 doesn't exist
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.1.0.0 doesn't exist
  dependency containers-0.2.0.1 doesn't exist
  dependency directory-1.0.0.3 doesn't exist
  dependency filepath-1.1.0.2 doesn't exist
  dependency haskell98-1.0.1.0 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
There are problems in package ghc-6.10.2:
  dependency Cabal-1.6.0.3 doesn't exist
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.1.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.1 doesn't exist
  dependency directory-1.0.0.3 doesn't exist
  dependency editline-0.2.1.0 doesn't exist
  dependency filepath-1.1.0.2 doesn't exist
  dependency haskell98-1.0.1.0 doesn't exist
  dependency hpc-0.5.0.3 doesn't exist
  dependency old-time-1.0.0.2 doesn't exist
  dependency process-1.0.1.1 doesn't exist
  dependency template-haskell-2.3.0.1 doesn't exist
  dependency unix-2.3.2.0 doesn't exist

The following packages are broken, either because they have a problem
listed above, or because they depend on a broken package.
haddock-2.4.2
ghc-6.10.2

Listing user packages ( ghc-pkg list --user ) shows that ghc-pkg is looking
for a package.conf in ~/.ghc/i386-linux-6.10.2/package.conf which doesn't
exist:. So I created it and copied over the package.conf file from
~/.ghc/i386-linux-6.10.1/ and ran ghc-pkg check again with the following
error :

There are problems in package CC-delcont-0.2:
  dependency base-3.0.3.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
There are problems in package terminfo-0.2.2.1:
  dependency base-3.0.3.0 doesn't exist
There are problems in package darcs-2.2.0:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency html-1.0.1.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency process-1.0.1.0 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency regex-compat-0.71.0.1 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package extensible-exceptions-0.1.1.0:
  dependency base-4.0.0.0 doesn't exist
There are problems in package binary-0.4.4:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
There are problems in package syb-with-class-0.4:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package hspread-0.3.1:
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
There are problems in package happstack-state-0.1:
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency stm-2.1.1.2 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package happstack-ixset-0.1:
  dependency base-4.0.0.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-server-0.1:
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency html-1.0.1.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency process-1.0.1.0 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
  dependency xhtml-3000.2.0.1 doesn't exist
There are problems in package happstack-contrib-0.1:
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package X11-1.4.5:
  dependency base-3.0.3.0 doesn't exist
There are problems in package xmonad-0.8.1:
  dependency base-3.0.3.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency process-1.0.1.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package utf8-string-0.3.4:
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
There are problems in package X11-xft-0.3:
  dependency base-3.0.3.0 doesn't exist
There are problems in package ghc-paths-0.1.0.5:
  dependency base-3.0.3.0 doesn't exist
There are problems in package haddock-2.4.1:
  dependency Cabal-1.6.0.1 doesn't exist
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency ghc-6.10.1 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
There are problems in package regex-base-0.93.1:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
There are problems in package regex-posix-0.94.1:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
There are problems in package regex-compat-0.92:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
There are problems in package syb-with-class-0.5.1:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package terminfo-0.3:
  dependency base-3.0.3.0 doesn't exist
There are problems in package time-1.1.2.3:
  dependency base-3.0.3.0 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
There are problems in package xmonad-contrib-0.8.1:
  dependency base-3.0.3.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency process-1.0.1.0 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package wxcore-0.11.0:
  dependency base-4.0.0.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency stm-2.1.1.2 doesn't exist
There are problems in package process-1.0.1.1:
  dependency base-4.0.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package darcs-2.2.1:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency html-1.0.1.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package haskell98-1.0.1.0:
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
There are problems in package HaXml-1.13.3:
  dependency base-3.0.3.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
There are problems in package terminfo-0.3.0.1:
  dependency base-3.0.3.0 doesn't exist
There are problems in package hslogger-1.0.7:
  dependency base-3.0.3.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package happstack-util-0.1:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency QuickCheck-1.2.0.0 doesn't exist
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-data-0.1:
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-util-0.1.9:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency QuickCheck-1.2.0.0 doesn't exist
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-data-0.1.9:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-state-0.1.9:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency stm-2.1.1.2 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package happstack-ixset-0.1.9:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package MaybeT-0.1.2:
  dependency base-3.0.3.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
There are problems in package zlib-0.5.0.0:
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
There are problems in package happstack-server-0.1.9:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency html-1.0.1.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
  dependency xhtml-3000.2.0.1 doesn't exist
There are problems in package happstack-contrib-0.1.9:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package HJavaScript-0.4.4:
  dependency base-3.0.3.0 doesn't exist
There are problems in package cpphs-1.6:
  dependency base-3.0.3.0 doesn't exist
There are problems in package harp-0.4:
  dependency base-3.0.3.0 doesn't exist
There are problems in package haskell-src-exts-0.4.8:
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
There are problems in package hsx-0.4.8:
  dependency base-3.0.3.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
There are problems in package HJScript-0.4.4:
  dependency base-3.0.3.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
There are problems in package hsp-0.4.5:
  dependency base-3.0.3.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
There are problems in package happstack-0.1.9:
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
There are problems in package Xauth-0.1:
  dependency base-3.0.3.0 doesn't exist
There are problems in package byteorder-1.0.0:
  dependency base-3.0.3.0 doesn't exist
There are problems in package xhb-0.2.2009.2.21:
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency stm-2.1.1.2 doesn't exist
There are problems in package HStringTemplate-0.4.3:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
There are problems in package happstack-util-0.2.1:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency QuickCheck-1.2.0.0 doesn't exist
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-data-0.2.1:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-ixset-0.2.1:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-server-0.2.1:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency html-1.0.1.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
  dependency xhtml-3000.2.0.1 doesn't exist
There are problems in package happstack-state-0.2.1:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency stm-2.1.1.2 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package happstack-0.2.1:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
There are problems in package uniplate-1.2.0.3:
  dependency base-4.0.0.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
There are problems in package wx-0.11.0:
  dependency base-4.0.0.0 doesn't exist
  dependency stm-2.1.1.2 doesn't exist
There are problems in package wx-0.11.1.2:
  dependency base-4.0.0.0 doesn't exist
  dependency stm-2.1.1.2 doesn't exist
  dependency wxcore-0.11.1.2 doesn't exist
There are problems in package bimap-0.2.4:
  dependency base-3.0.3.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
There are problems in package encoding-0.5.1:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package fclabels-0.1:
  dependency base-3.0.3.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package hscolour-1.11:
  dependency base-3.0.3.0 doesn't exist
There are problems in package parsec-3.0.0:
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
There are problems in package pureMD5-0.2.4:
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
There are problems in package salvia-0.1.1:
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency stm-2.1.1.2 doesn't exist
There are problems in package salvia-extras-0.1.1:
  dependency base-3.0.3.0 doesn't exist
There are problems in package Diff-0.1.2:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
There are problems in package clevercss-0.1.1:
  dependency base-3.0.3.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
There are problems in package datetime-0.1:
  dependency QuickCheck-1.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
There are problems in package nano-md5-0.1.2:
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
There are problems in package network-2.2.0.1:
  dependency base-4.0.0.0 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
There are problems in package split-0.1.1:
  dependency base-3.0.3.0 doesn't exist
There are problems in package xml-1.3.4:
  dependency base-3.0.3.0 doesn't exist
There are problems in package filestore-0.2:
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
There are problems in package hsemail-1.3:
  dependency base-3.0.3.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
There are problems in package SMTPClient-1.0.1:
  dependency base-3.0.3.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
There are problems in package HTTP-4000.0.4:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
There are problems in package happstack-util-0.3:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency QuickCheck-1.2.0.0 doesn't exist
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-data-0.3:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-state-0.3:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency random-1.0.0.1 doesn't exist
  dependency stm-2.1.1.2 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package happstack-ixset-0.3:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
There are problems in package happstack-server-0.3:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.0 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency html-1.0.1.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-locale-1.0.0.1 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency template-haskell-2.3.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
  dependency xhtml-3000.2.0.1 doesn't exist
There are problems in package happstack-contrib-0.3:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package FileManip-0.3.2:
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency unix-2.3.1.0 doesn't exist
There are problems in package happstack-0.3:
  dependency HUnit-1.2.0.3 doesn't exist
  dependency base-4.0.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency directory-1.0.0.2 doesn't exist
  dependency filepath-1.1.0.1 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency syb-0.1.0.0 doesn't exist
There are problems in package HTTP-4000.0.5:
  dependency array-0.2.0.0 doesn't exist
  dependency base-3.0.3.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency mtl-1.1.0.2 doesn't exist
  dependency old-time-1.0.0.1 doesn't exist
  dependency parsec-2.1.0.1 doesn't exist
There are problems in package haddock-2.4.2:
  dependency Cabal-1.6.0.3 doesn't exist
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.1.0.0 doesn't exist
  dependency containers-0.2.0.1 doesn't exist
  dependency directory-1.0.0.3 doesn't exist
  dependency filepath-1.1.0.2 doesn't exist
  dependency pretty-1.0.1.0 doesn't exist
There are problems in package ghc-6.10.2:
  dependency Cabal-1.6.0.3 doesn't exist
  dependency array-0.2.0.0 doesn't exist
  dependency base-4.1.0.0 doesn't exist
  dependency bytestring-0.9.1.4 doesn't exist
  dependency containers-0.2.0.1 doesn't exist
  dependency directory-1.0.0.3 doesn't exist
  dependency editline-0.2.1.0 doesn't exist
  dependency filepath-1.1.0.2 doesn't exist
  dependency hpc-0.5.0.3 doesn't exist
  dependency old-time-1.0.0.2 doesn't exist
  dependency template-haskell-2.3.0.1 doesn't exist
  dependency unix-2.3.2.0 doesn't exist

The following packages are broken, either because they have a problem
listed above, or because they depend on a broken package.
CC-delcont-0.2
terminfo-0.2.2.1
darcs-2.2.0
extensible-exceptions-0.1.1.0
binary-0.4.4
syb-with-class-0.4
hspread-0.3.1
happstack-state-0.1
happstack-ixset-0.1
happstack-server-0.1
happstack-contrib-0.1
X11-1.4.5
xmonad-0.8.1
utf8-string-0.3.4
X11-xft-0.3
ghc-paths-0.1.0.5
haddock-2.4.1
regex-base-0.93.1
regex-posix-0.94.1
regex-compat-0.92
syb-with-class-0.5.1
terminfo-0.3
time-1.1.2.3
xmonad-contrib-0.8.1
wxcore-0.11.0
process-1.0.1.1
darcs-2.2.1
haskell98-1.0.1.0
HaXml-1.13.3
terminfo-0.3.0.1
hslogger-1.0.7
happstack-util-0.1
happstack-data-0.1
happstack-util-0.1.9
happstack-data-0.1.9
happstack-state-0.1.9
happstack-ixset-0.1.9
MaybeT-0.1.2
zlib-0.5.0.0
happstack-server-0.1.9
happstack-contrib-0.1.9
HJavaScript-0.4.4
cpphs-1.6
harp-0.4
haskell-src-exts-0.4.8
hsx-0.4.8
HJScript-0.4.4
hsp-0.4.5
happstack-0.1.9
Xauth-0.1
byteorder-1.0.0
xhb-0.2.2009.2.21
HStringTemplate-0.4.3
happstack-util-0.2.1
happstack-data-0.2.1
happstack-ixset-0.2.1
happstack-server-0.2.1
happstack-state-0.2.1
happstack-0.2.1
uniplate-1.2.0.3
wx-0.11.0
wx-0.11.1.2
bimap-0.2.4
encoding-0.5.1
fclabels-0.1
hscolour-1.11
parsec-3.0.0
pureMD5-0.2.4
salvia-0.1.1
salvia-extras-0.1.1
Diff-0.1.2
clevercss-0.1.1
datetime-0.1
nano-md5-0.1.2
network-2.2.0.1
split-0.1.1
xml-1.3.4
filestore-0.2
hsemail-1.3
SMTPClient-1.0.1
HTTP-4000.0.4
happstack-util-0.3
happstack-data-0.3
happstack-state-0.3
happstack-ixset-0.3
happstack-server-0.3
happstack-contrib-0.3
FileManip-0.3.2
happstack-0.3
HTTP-4000.0.5
haddock-2.4.2
ghc-6.10.2

Did I do something wrong in the installation step?

thanks ...
-deech
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/beginners/attachments/20090428/48e08f64/attachment-0001.htm