Problem upgrading xmonad via cabal

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem upgrading xmonad via cabal

Eyal Erez
Hi,

I've recently tried to upgrade xmonad to the latest version but have been experiencing some problems.  My guess is that the version I'm getting from cabal is conflicting with Fedora's packaged version, but I'm not sure how to disentangle.

I've tried the following, any suggestions would be most welcome:

> cabal --version
cabal-install version 2.4.1.0
compiled using version 2.4.1.0 of the Cabal library 
> cabal update
Warning: The update command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-update command
or the legacy v1-update alias as new-style projects will become the default in
the next version of cabal-install. Please file a bug if you cannot replicate a
working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Downloading the latest package list from hackage.haskell.org
To revert to previous state run:
    cabal update --index-state='2020-02-24T08:44:25Z'
> cabal install xmonad
Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
All the requested packages are already installed:
xmonad-0.15
Use --reinstall if you want to reinstall anyway.
> cabal install xmonad --reinstall
Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
In order, the following would be installed:
xmonad-0.15 (reinstall)
cabal: The following packages are likely to be broken by the reinstalls:
xmonad-contrib-0.16
xmonad-contrib-0.15
Use --force-reinstalls if you want to install anyway.


_______________________________________________
xmonad mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/xmonad
Reply | Threaded
Open this post in threaded view
|

Re: Problem upgrading xmonad via cabal

Eyal Erez
I've also tried upgrading cabal itself and I get the following:

> cabal install Cabal cabal-install
Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] next goal: Cabal (user goal)
[__0] rejecting: Cabal-3.0.0.0/installed-3B7... (package is broken)
[__0] trying: Cabal-3.0.0.0
[__1] trying: unix-2.7.2.2/installed-2.7... (dependency of Cabal)
[__2] next goal: time (dependency of Cabal)
[__2] rejecting: time-1.9.3/installed-Hzi... (conflict: unix =>
time==1.8.0.2/installed-1.8...)
[__2] trying: time-1.8.0.2/installed-1.8...
[__3] trying: process-1.6.7.0/installed-nGT... (dependency of Cabal)
[__4] trying: directory-1.3.6.0/installed-86L... (dependency of Cabal)
[__5] trying: base-4.11.1.0/installed-4.1... (dependency of Cabal)
[__6] trying: cabal-install-3.0.0.0 (user goal)
[__7] next goal: hackage-security (dependency of cabal-install)
[__7] rejecting: hackage-security-0.6.0.0/installed-GMN...,
hackage-security-0.5.3.0/installed-Et0... (package is broken)
[__7] rejecting: hackage-security-0.6.0.0 (conflict: cabal-install =>
hackage-security>=0.5.2.2 && <0.6)
[__7] trying: hackage-security-0.5.3.0
[__8] next goal: template-haskell (dependency of hackage-security)
[__8] rejecting: template-haskell-2.15.0.0, template-haskell-2.14.0.0,
template-haskell-2.13.0.0 (only already installed instances can be used)
[__8] rejecting: template-haskell-2.12.0.0 (conflict: unix =>
base==4.11.1.0/installed-4.1..., template-haskell => base>=4.8 && <4.11)
[__8] rejecting: template-haskell-2.11.1.0, template-haskell-2.11.0.0
(conflict: unix => base==4.11.1.0/installed-4.1..., template-haskell =>
base>=4.7 && <4.10)
[__8] rejecting: template-haskell-2.10.0.0 (conflict: unix =>
base==4.11.1.0/installed-4.1..., template-haskell => base==4.8.*)
[__8] rejecting: template-haskell-2.9.0.0 (conflict: unix =>
base==4.11.1.0/installed-4.1..., template-haskell => base==4.7.*)
[__8] rejecting: template-haskell-2.8.0.0 (conflict: unix =>
base==4.11.1.0/installed-4.1..., template-haskell => base==4.6.*)
[__8] rejecting: template-haskell-2.7.0.0 (conflict: unix =>
base==4.11.1.0/installed-4.1..., template-haskell => base==4.5.*)
[__8] rejecting: template-haskell-2.6.0.0 (conflict: unix =>
base==4.11.1.0/installed-4.1..., template-haskell => base==4.4.*)
[__8] rejecting: template-haskell-2.5.0.0 (conflict: unix =>
base==4.11.1.0/installed-4.1..., template-haskell => base==4.3.*)
[__8] rejecting: template-haskell-2.4.0.1 (conflict: unix =>
base==4.11.1.0/installed-4.1..., template-haskell => base==4.2.*)
[__8] rejecting: template-haskell-2.4.0.0 (conflict: unix =>
base==4.11.1.0/installed-4.1..., template-haskell => base>=3 && <4.3)
[__8] rejecting: template-haskell-2.3.0.1, template-haskell-2.3.0.0,
template-haskell-2.2.0.0 (conflict: unix => base==4.11.1.0/installed-4.1...,
template-haskell => base<4.3)
[__8] fail (backjumping, conflict set: hackage-security, template-haskell,
unix)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: cabal-install, HTTP, base, Cabal,
time, directory, process, template-haskell, hackage-security, unix,
cabal-install:lib


On Thu, Mar 12, 2020 at 12:53 AM Eyal Erez <[hidden email]> wrote:
Hi,

I've recently tried to upgrade xmonad to the latest version but have been experiencing some problems.  My guess is that the version I'm getting from cabal is conflicting with Fedora's packaged version, but I'm not sure how to disentangle.

I've tried the following, any suggestions would be most welcome:

> cabal --version
cabal-install version 2.4.1.0
compiled using version 2.4.1.0 of the Cabal library 
> cabal update
Warning: The update command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-update command
or the legacy v1-update alias as new-style projects will become the default in
the next version of cabal-install. Please file a bug if you cannot replicate a
working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Downloading the latest package list from hackage.haskell.org
To revert to previous state run:
    cabal update --index-state='2020-02-24T08:44:25Z'
> cabal install xmonad
Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
All the requested packages are already installed:
xmonad-0.15
Use --reinstall if you want to reinstall anyway.
> cabal install xmonad --reinstall
Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
In order, the following would be installed:
xmonad-0.15 (reinstall)
cabal: The following packages are likely to be broken by the reinstalls:
xmonad-contrib-0.16
xmonad-contrib-0.15
Use --force-reinstalls if you want to install anyway.



--
Eyal Erez <[hidden email]>

There are 10 types of people, those who know binary and those who don't.


_______________________________________________
xmonad mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/xmonad