Problems building and using ghc-6.9

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems building and using ghc-6.9

Daniel Fischer-4
Hi,
so today I built ghc-6.9.20071124.

First, make died because HsColour version >= 1.8 was needed, couldn't
determine the version. I had HsColour 1.6, got myself 1.8, built and
installed.
make died again, same problem.
I added ("v", Version) to the optionTable in HsColour.hs and it worked :)

Then I tried to build zlib-0.4.0.1:
$ runghc ./Setup.hs configure --user --prefix=$HOME
Configuring zlib-0.4.0.1...
Setup.hs: At least the following dependencies are missing:
    base >=2.0&&<2.2
??? okay, there was something with flag bytestring-in-base, removed that, so
that build-depends was base < 2.0 || >= 2.2, bytestring >= 0.9, then
$ runghc ./Setup.hs configure --user --prefix=$HOME
Configuring zlib-0.4.0.1...
Setup.hs: At least the following dependencies are missing:
    base <2.0||>=2.2, bytestring >=0.9

but:
$ ghc-pkg list
/home/dafis/lib/ghc-6.9.20071124/package.conf:
    ALUT-2.1.0.0, Cabal-1.3, GLUT-2.1.1.1, HUnit-1.2.0.0,
    OpenAL-1.3.1.1, OpenGL-2.2.1.1, QuickCheck-1.1.0.0, array-0.1,
    base-3.0, bytestring-0.9, cgi-3001.1.5.1, containers-0.1,
    directory-1.0, fgl-5.4.1.1, filepath-1.1, (ghc-6.9.20071124),
    haskell-src-1.0.1.1, haskell98-1.0.1, hpc-0.5, html-1.0.1.1,
    mtl-1.1.0.0, network-2.1.0.0, old-locale-1.0, old-time-1.0,
    packedstring-0.1, parallel-1.0.0.0, parsec-2.1.0.0, pretty-1.0,
    process-1.0, random-1.0, readline-1.0.1, regex-base-0.72.0.1,
    regex-compat-0.71.0.1, regex-posix-0.72.0.2, rts-1.0, stm-2.1.1.0,
    template-haskell-2.2, time-1.1.2.0, unix-2.2, xhtml-3000.0.2.1

and in stringsearch-0.2:
$ runghc ./Setup.lhs configure --user --prefix=$HOME
Configuring stringsearch-0.2...
Setup.lhs: At least the following dependencies are missing:
    base -any

What's going on??

How can I build packages with ghc-6.9?
Or do I have to go back to 6.8.1?

Thanks,
Daniel
_______________________________________________
Glasgow-haskell-users mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/glasgow-haskell-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems building and using ghc-6.9

Simon Marlow-5
Daniel Fischer wrote:

> Then I tried to build zlib-0.4.0.1:
> $ runghc ./Setup.hs configure --user --prefix=$HOME
> Configuring zlib-0.4.0.1...
> Setup.hs: At least the following dependencies are missing:
>     base >=2.0&&<2.2
> ??? okay, there was something with flag bytestring-in-base, removed that, so
> that build-depends was base < 2.0 || >= 2.2, bytestring >= 0.9, then
> $ runghc ./Setup.hs configure --user --prefix=$HOME
> Configuring zlib-0.4.0.1...
> Setup.hs: At least the following dependencies are missing:
>     base <2.0||>=2.2, bytestring >=0.9

This turns out to be something that broke when we changed the command-line
syntax for ghc-pkg in the HEAD.  I've just posted a patch for Cabal on
[hidden email].

Cheers,
        Simon
_______________________________________________
Glasgow-haskell-users mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/glasgow-haskell-users