Re: [Haskell-cafe] [ANNOUNCE] GHC 8.8.1 and cabal-install version

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [Haskell-cafe] [ANNOUNCE] GHC 8.8.1 and cabal-install version

Donn Cave-4
> https://www.haskell.org/ghc/blog/20190825-ghc-8.8.1-released.html says
>
> cabal-install users should note that cabal-install-3.0 or later is
> required for use with GHC 8.8.

I'm not the most sophisticated user of cabal-install ever, but it appears
to me that 8.8.1 can't build 3.0.0.0?  depends on base >= 4.8 && < 4.13,
where 8.8.1 installs base-4.13.0.0.

I'm working with cabal-install-3.0.0.0.tar.gz .  It looks like it might
be possible to up some of the dependencies, like HTTP to 4000.3.14, but
I suppose there's a reason why cabal-install itself isn't there yet.

        Donn
_______________________________________________
Glasgow-haskell-users mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/glasgow-haskell-users
Reply | Threaded
Open this post in threaded view
|

Re: [Haskell-cafe] [ANNOUNCE] GHC 8.8.1 and cabal-install version

Herbert Valerio Riedel-3

On Tue, Sep 10, 2019 at 12:06 AM Donn Cave <[hidden email]> wrote:
> https://www.haskell.org/ghc/blog/20190825-ghc-8.8.1-released.html says
>
> cabal-install users should note that cabal-install-3.0 or later is
> required for use with GHC 8.8.

I'm not the most sophisticated user of cabal-install ever, but it appears
to me that 8.8.1 can't build 3.0.0.0?  depends on base >= 4.8 && < 4.13,
where 8.8.1 installs base-4.13.0.0.

lib:Cabal 3.0.0.0 can be build with GHC 8.8.1 as is evidenced by


it's just the executable exe:cabal 3.0.0.0 that can't be build with GHC 8.8.1; It can however be built with GHC 7.10.3 through GHC 8.6.5 as evidenced by


However, exe:cabal 3.0.0.1 among other things is planned to be buildable also with GHC 8.8.1

But it's perfectly fine to use an exe:cabal built with a different GHC than the one you want to use it with; in fact exe:cabal supports being used with all GHCs going back to GHC 7.0 (even though you can't build exe:cabal with GHC 7.0 anymore)
 
I'm working with cabal-install-3.0.0.0.tar.gz .  It looks like it might
be possible to up some of the dependencies, like HTTP to 4000.3.14, but
I suppose there's a reason why cabal-install itself isn't there yet.

Indeed, the main reason is that some of its dependencies weren't GHC-8.8.1-compatible yet at the time its release. So we didn't yet bother to update the bootstrap script yet.


What operating system are you on? is it possible for you to use one of the binaries from http://downloads.haskell.org/~cabal/cabal-install-3.0.0.0/ in the meantime? 

Herbert

_______________________________________________
Glasgow-haskell-users mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/glasgow-haskell-users
Reply | Threaded
Open this post in threaded view
|

Re: GHC 8.8.1 and cabal-install version

Donn Cave-4
> What operating system are you on? is it possible for you to use one of the
> binaries from http://downloads.haskell.org/~cabal/cabal-install-3.0.0.0/ in
> the meantime?

It's Haiku, not exactly one of the major operating systems.

I'm not in any hurry, I suppose I'll just let it rest and check
back later to see if things have improved.  It's too bad 8.8.1
breaks so much stuff, but I guess one gets used to that.

        Donn
_______________________________________________
Glasgow-haskell-users mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/glasgow-haskell-users