Stack could not find libHStransformers

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Stack could not find libHStransformers

Quentin Liu
Hi,

I was trying to use Parsec and imported Text.ParserCombinators.Parsec. I could call “stack ghc” to compile the file, but when I loaded the file into ghci and called any function, ghci would report errors
can't load .so/.DLL for: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib (dlopen(/Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib, 5): Library not loaded: /usr/local/opt/ghc/lib/ghc-8.0.2/transformers-0.5.2.0/libHStransformers-0.5.2.0-ghc8.0.2.dylib
  Referenced from: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib
  Reason: image not found)


I tried to install transformers by calling `stack install transformers` but the problem still persisted. Is it because the version of transformers in my repo is different from the one referenced by `mtl` package? How should I fix it?

Regards,
Qingbo Liu

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: Stack could not find libHStransformers

Michael Snoyman
What version of Stack are you using (stack --version), and how did you install Stack and GHC?

It looks like you're using a system-wide GHC installation, which (for reasons like this) we by default no longer use by default in recent Stack releases.

Upgrading to the latest Stack (via `stack upgrade` or following the instructions at [1]) will probably solve the problem.


On Thu, Dec 7, 2017 at 8:43 AM, Quentin Liu <[hidden email]> wrote:
Hi,

I was trying to use Parsec and imported Text.ParserCombinators.Parsec. I could call “stack ghc” to compile the file, but when I loaded the file into ghci and called any function, ghci would report errors
can't load .so/.DLL for: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib (dlopen(/Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib, 5): Library not loaded: /usr/local/opt/ghc/lib/ghc-8.0.2/transformers-0.5.2.0/libHStransformers-0.5.2.0-ghc8.0.2.dylib
  Referenced from: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib
  Reason: image not found)


I tried to install transformers by calling `stack install transformers` but the problem still persisted. Is it because the version of transformers in my repo is different from the one referenced by `mtl` package? How should I fix it?

Regards,
Qingbo Liu

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners



_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: Stack could not find libHStransformers

Quentin Liu
I am using ghc download and managed by stack. My stack is of the latest version, which is 1.6.1. 

Regards,
Qingbo Liu

On Dec 7, 2017, 01:56 -0500, Michael Snoyman <[hidden email]>, wrote:
What version of Stack are you using (stack --version), and how did you install Stack and GHC?

It looks like you're using a system-wide GHC installation, which (for reasons like this) we by default no longer use by default in recent Stack releases.

Upgrading to the latest Stack (via `stack upgrade` or following the instructions at [1]) will probably solve the problem.


On Thu, Dec 7, 2017 at 8:43 AM, Quentin Liu <[hidden email]> wrote:
Hi,

I was trying to use Parsec and imported Text.ParserCombinators.Parsec. I could call “stack ghc” to compile the file, but when I loaded the file into ghci and called any function, ghci would report errors
can't load .so/.DLL for: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib (dlopen(/Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib, 5): Library not loaded: /usr/local/opt/ghc/lib/ghc-8.0.2/transformers-0.5.2.0/libHStransformers-0.5.2.0-ghc8.0.2.dylib
  Referenced from: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib
  Reason: image not found)


I tried to install transformers by calling `stack install transformers` but the problem still persisted. Is it because the version of transformers in my repo is different from the one referenced by `mtl` package? How should I fix it?

Regards,
Qingbo Liu

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: Stack could not find libHStransformers

Michael Snoyman
Some ideas:

* What does this output: `which ghc ; stack exec which ghc`
* What does your stack.yaml look like?
* Do you have a .ghci or other kinds of local configuration file?

On Thu, Dec 7, 2017 at 5:42 PM, Quentin Liu <[hidden email]> wrote:
I am using ghc download and managed by stack. My stack is of the latest version, which is 1.6.1. 

Regards,
Qingbo Liu

On Dec 7, 2017, 01:56 -0500, Michael Snoyman <[hidden email]>, wrote:
What version of Stack are you using (stack --version), and how did you install Stack and GHC?

It looks like you're using a system-wide GHC installation, which (for reasons like this) we by default no longer use by default in recent Stack releases.

Upgrading to the latest Stack (via `stack upgrade` or following the instructions at [1]) will probably solve the problem.


On Thu, Dec 7, 2017 at 8:43 AM, Quentin Liu <[hidden email]> wrote:
Hi,

I was trying to use Parsec and imported Text.ParserCombinators.Parsec. I could call “stack ghc” to compile the file, but when I loaded the file into ghci and called any function, ghci would report errors
can't load .so/.DLL for: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib (dlopen(/Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib, 5): Library not loaded: /usr/local/opt/ghc/lib/ghc-8.0.2/transformers-0.5.2.0/libHStransformers-0.5.2.0-ghc8.0.2.dylib
  Referenced from: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib
  Reason: image not found)


I tried to install transformers by calling `stack install transformers` but the problem still persisted. Is it because the version of transformers in my repo is different from the one referenced by `mtl` package? How should I fix it?

Regards,
Qingbo Liu

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners



_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: Stack could not find libHStransformers

Quentin Liu
What does this output: `which ghc ; stack exec which ghc`
`which ghc` gives "ghc not found”, while `stack exec which ghc` gives "/Users/HereWegoR/.stack/programs/x86_64-osx/ghc-8.0.2/bin/ghc”. 

What does your stack.yaml look like?
For this file I don’t have any stack.yaml. I just wrote the file and tried to load it into ghci. 

Do you have a .ghci or other kinds of local configuration file?
As far as I can tell, no. 

Regards,
Qingbo Liu

On Dec 7, 2017, 11:33 -0500, Michael Snoyman <[hidden email]>, wrote:
Some ideas:

* What does this output: `which ghc ; stack exec which ghc`
* What does your stack.yaml look like?
* Do you have a .ghci or other kinds of local configuration file?

On Thu, Dec 7, 2017 at 5:42 PM, Quentin Liu <[hidden email]> wrote:
I am using ghc download and managed by stack. My stack is of the latest version, which is 1.6.1. 

Regards,
Qingbo Liu

On Dec 7, 2017, 01:56 -0500, Michael Snoyman <[hidden email]>, wrote:
What version of Stack are you using (stack --version), and how did you install Stack and GHC?

It looks like you're using a system-wide GHC installation, which (for reasons like this) we by default no longer use by default in recent Stack releases.

Upgrading to the latest Stack (via `stack upgrade` or following the instructions at [1]) will probably solve the problem.


On Thu, Dec 7, 2017 at 8:43 AM, Quentin Liu <[hidden email]> wrote:
Hi,

I was trying to use Parsec and imported Text.ParserCombinators.Parsec. I could call “stack ghc” to compile the file, but when I loaded the file into ghci and called any function, ghci would report errors
can't load .so/.DLL for: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib (dlopen(/Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib, 5): Library not loaded: /usr/local/opt/ghc/lib/ghc-8.0.2/transformers-0.5.2.0/libHStransformers-0.5.2.0-ghc8.0.2.dylib
  Referenced from: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib
  Reason: image not found)


I tried to install transformers by calling `stack install transformers` but the problem still persisted. Is it because the version of transformers in my repo is different from the one referenced by `mtl` package? How should I fix it?

Regards,
Qingbo Liu

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: Stack could not find libHStransformers

Michael Snoyman
I'm not sure how it happened, but it looks like you ended up with some files in ~/.stack which are linked against a system-wide GHC. In particular:

Library not loaded: /usr/local/opt/ghc/lib/ghc-8.0.2/transformers-0.5.2.0/libHStransformers-0.5.2.0-ghc8.0.2.dylib

The easiest way to fix this is to just wipe out your ~/.stack directory, which will result in having to do some recompiles, but otherwise should be harmless.

On Thu, Dec 7, 2017 at 7:05 PM, Quentin Liu <[hidden email]> wrote:
What does this output: `which ghc ; stack exec which ghc`
`which ghc` gives "ghc not found”, while `stack exec which ghc` gives "/Users/HereWegoR/.stack/programs/x86_64-osx/ghc-8.0.2/bin/ghc”. 

What does your stack.yaml look like?
For this file I don’t have any stack.yaml. I just wrote the file and tried to load it into ghci. 

Do you have a .ghci or other kinds of local configuration file?
As far as I can tell, no. 

Regards,
Qingbo Liu

On Dec 7, 2017, 11:33 -0500, Michael Snoyman <[hidden email]>, wrote:
Some ideas:

* What does this output: `which ghc ; stack exec which ghc`
* What does your stack.yaml look like?
* Do you have a .ghci or other kinds of local configuration file?

On Thu, Dec 7, 2017 at 5:42 PM, Quentin Liu <[hidden email]> wrote:
I am using ghc download and managed by stack. My stack is of the latest version, which is 1.6.1. 

Regards,
Qingbo Liu

On Dec 7, 2017, 01:56 -0500, Michael Snoyman <[hidden email]>, wrote:
What version of Stack are you using (stack --version), and how did you install Stack and GHC?

It looks like you're using a system-wide GHC installation, which (for reasons like this) we by default no longer use by default in recent Stack releases.

Upgrading to the latest Stack (via `stack upgrade` or following the instructions at [1]) will probably solve the problem.


On Thu, Dec 7, 2017 at 8:43 AM, Quentin Liu <[hidden email]> wrote:
Hi,

I was trying to use Parsec and imported Text.ParserCombinators.Parsec. I could call “stack ghc” to compile the file, but when I loaded the file into ghci and called any function, ghci would report errors
can't load .so/.DLL for: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib (dlopen(/Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib, 5): Library not loaded: /usr/local/opt/ghc/lib/ghc-8.0.2/transformers-0.5.2.0/libHStransformers-0.5.2.0-ghc8.0.2.dylib
  Referenced from: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib
  Reason: image not found)


I tried to install transformers by calling `stack install transformers` but the problem still persisted. Is it because the version of transformers in my repo is different from the one referenced by `mtl` package? How should I fix it?

Regards,
Qingbo Liu

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners



_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: Stack could not find libHStransformers

Quentin Liu
Thanks! It really helps.

Regards,
Qingbo Liu

On Dec 7, 2017, 12:31 -0500, Michael Snoyman <[hidden email]>, wrote:
I'm not sure how it happened, but it looks like you ended up with some files in ~/.stack which are linked against a system-wide GHC. In particular:

Library not loaded: /usr/local/opt/ghc/lib/ghc-8.0.2/transformers-0.5.2.0/libHStransformers-0.5.2.0-ghc8.0.2.dylib

The easiest way to fix this is to just wipe out your ~/.stack directory, which will result in having to do some recompiles, but otherwise should be harmless.

On Thu, Dec 7, 2017 at 7:05 PM, Quentin Liu <[hidden email]> wrote:
What does this output: `which ghc ; stack exec which ghc`
`which ghc` gives "ghc not found”, while `stack exec which ghc` gives "/Users/HereWegoR/.stack/programs/x86_64-osx/ghc-8.0.2/bin/ghc”. 

What does your stack.yaml look like?
For this file I don’t have any stack.yaml. I just wrote the file and tried to load it into ghci. 

Do you have a .ghci or other kinds of local configuration file?
As far as I can tell, no. 

Regards,
Qingbo Liu

On Dec 7, 2017, 11:33 -0500, Michael Snoyman <[hidden email]>, wrote:
Some ideas:

* What does this output: `which ghc ; stack exec which ghc`
* What does your stack.yaml look like?
* Do you have a .ghci or other kinds of local configuration file?

On Thu, Dec 7, 2017 at 5:42 PM, Quentin Liu <[hidden email]> wrote:
I am using ghc download and managed by stack. My stack is of the latest version, which is 1.6.1. 

Regards,
Qingbo Liu

On Dec 7, 2017, 01:56 -0500, Michael Snoyman <[hidden email]>, wrote:
What version of Stack are you using (stack --version), and how did you install Stack and GHC?

It looks like you're using a system-wide GHC installation, which (for reasons like this) we by default no longer use by default in recent Stack releases.

Upgrading to the latest Stack (via `stack upgrade` or following the instructions at [1]) will probably solve the problem.


On Thu, Dec 7, 2017 at 8:43 AM, Quentin Liu <[hidden email]> wrote:
Hi,

I was trying to use Parsec and imported Text.ParserCombinators.Parsec. I could call “stack ghc” to compile the file, but when I loaded the file into ghci and called any function, ghci would report errors
can't load .so/.DLL for: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib (dlopen(/Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib, 5): Library not loaded: /usr/local/opt/ghc/lib/ghc-8.0.2/transformers-0.5.2.0/libHStransformers-0.5.2.0-ghc8.0.2.dylib
  Referenced from: /Users/HereWegoR/.stack/snapshots/x86_64-osx/lts-8.8/8.0.2/lib/x86_64-osx-ghc-8.0.2/libHSmtl-2.2.1-BLKBelFsPB3BoFeSWSOYj6-ghc8.0.2.dylib
  Reason: image not found)


I tried to install transformers by calling `stack install transformers` but the problem still persisted. Is it because the version of transformers in my repo is different from the one referenced by `mtl` package? How should I fix it?

Regards,
Qingbo Liu

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners