Support for glibc 2.12 in 7.8 RC2

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Support for glibc 2.12 in 7.8 RC2

Rob Stewart-2
Hi,

The 7.8 RC1 status page [1] states RC1 requires glibc 2.15, and that
RC2 will support glibc 2.13 to target Debian 7. CentOS 6 packages
glibc 2.12 and this will be the glibc version in the CentOS 6
lifetime.

Is there a possibility of stretching lower bounded support in RC2 down
to glibc 2.12? This would allow all CentOS users using any of the 6.*
releases to use 7.8, I think.

[1] https://ghc.haskell.org/trac/ghc/wiki/Status/GHC-7.8/RC1

--
Rob

Reply | Threaded
Open this post in threaded view
|

Support for glibc 2.12 in 7.8 RC2

Ryan Newton
Yes, this is a really annoying issue on RHEL, which includes many
supercomputers.

Sent from my phone.
On Feb 7, 2014 1:35 PM, "Rob Stewart" <robstewart57 at gmail.com> wrote:

> Hi,
>
> The 7.8 RC1 status page [1] states RC1 requires glibc 2.15, and that
> RC2 will support glibc 2.13 to target Debian 7. CentOS 6 packages
> glibc 2.12 and this will be the glibc version in the CentOS 6
> lifetime.
>
> Is there a possibility of stretching lower bounded support in RC2 down
> to glibc 2.12? This would allow all CentOS users using any of the 6.*
> releases to use 7.8, I think.
>
> [1] https://ghc.haskell.org/trac/ghc/wiki/Status/GHC-7.8/RC1
>
> --
> Rob
> _______________________________________________
> ghc-devs mailing list
> ghc-devs at haskell.org
> http://www.haskell.org/mailman/listinfo/ghc-devs
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/ghc-devs/attachments/20140207/40c210f9/attachment.html>

Reply | Threaded
Open this post in threaded view
|

Support for glibc 2.12 in 7.8 RC2

Simon Marlow-7
These are just the binary builds, you can bootstrap it on your own
system to support whatever glibc version you have.

Cheers,
Simon

On 07/02/2014 18:05, Ryan Newton wrote:

> Yes, this is a really annoying issue on RHEL, which includes many
> supercomputers.
>
> Sent from my phone.
>
> On Feb 7, 2014 1:35 PM, "Rob Stewart" <robstewart57 at gmail.com
> <mailto:robstewart57 at gmail.com>> wrote:
>
>     Hi,
>
>     The 7.8 RC1 status page [1] states RC1 requires glibc 2.15, and that
>     RC2 will support glibc 2.13 to target Debian 7. CentOS 6 packages
>     glibc 2.12 and this will be the glibc version in the CentOS 6
>     lifetime.
>
>     Is there a possibility of stretching lower bounded support in RC2 down
>     to glibc 2.12? This would allow all CentOS users using any of the 6.*
>     releases to use 7.8, I think.
>
>     [1] https://ghc.haskell.org/trac/ghc/wiki/Status/GHC-7.8/RC1
>
>     --
>     Rob
>     _______________________________________________
>     ghc-devs mailing list
>     ghc-devs at haskell.org <mailto:ghc-devs at haskell.org>
>     http://www.haskell.org/mailman/listinfo/ghc-devs
>
>
>
> _______________________________________________
> ghc-devs mailing list
> ghc-devs at haskell.org
> http://www.haskell.org/mailman/listinfo/ghc-devs
>