[Xmonad] mod events not reaching xmonad

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Xmonad] mod events not reaching xmonad

Bas van Dijk-2
Hello,

I have a problem. Often, after a while of using OpenOffice with xmonad
mod key events no longer get to xmonad. When this happens I'm forced
to switch to a console and killall xmonad loosing all non-saved work
in the process. I've also seen this using other applications like
Firefox for example. What can be causing this and do other people have
the same problems?

regards,

Bas van Dijk

P.S. I run the latest xmonad
Reply | Threaded
Open this post in threaded view
|

[Xmonad] Re: mod events not reaching xmonad

Bas van Dijk-2
It seems like I've located the problem. Because I was doing some
numeric input in OpenOffice Calc I enabled num-lock. This seems to
change to modMask.

So the "solution" is to disable num-lock before giving xmonad
commands. However this is not a very user friendly solution.

Bas
Reply | Threaded
Open this post in threaded view
|

[Xmonad] Re: mod events not reaching xmonad

Spencer Janssen-2
On Wed, 18 Apr 2007 13:04:18 +0200
"Bas van Dijk" <[hidden email]> wrote:

> It seems like I've located the problem. Because I was doing some
> numeric input in OpenOffice Calc I enabled num-lock. This seems to
> change to modMask.
>
> So the "solution" is to disable num-lock before giving xmonad
> commands. However this is not a very user friendly solution.

xmonad does attempt to ignore numlockMask, but this value is not the
same on all systems.  We're still looking for a more robust solution to
this.


Spencer Janssen
Reply | Threaded
Open this post in threaded view
|

[Xmonad] Re: mod events not reaching xmonad

Spencer Janssen-2
In reply to this post by Bas van Dijk-2
On Wed, 18 Apr 2007 13:04:18 +0200
"Bas van Dijk" <[hidden email]> wrote:

> It seems like I've located the problem. Because I was doing some
> numeric input in OpenOffice Calc I enabled num-lock. This seems to
> change to modMask.
>
> So the "solution" is to disable num-lock before giving xmonad
> commands. However this is not a very user friendly solution.

For now, you can find the value of your numlock mask with xev, and
change the numlockMask in Config.hs


Spencer Janssen
Reply | Threaded
Open this post in threaded view
|

[Xmonad] Re: mod events not reaching xmonad

Donald Bruce Stewart
In reply to this post by Spencer Janssen-2
sjanssen:

> On Wed, 18 Apr 2007 13:04:18 +0200
> "Bas van Dijk" <[hidden email]> wrote:
>
> > It seems like I've located the problem. Because I was doing some
> > numeric input in OpenOffice Calc I enabled num-lock. This seems to
> > change to modMask.
> >
> > So the "solution" is to disable num-lock before giving xmonad
> > commands. However this is not a very user friendly solution.
>
> xmonad does attempt to ignore numlockMask, but this value is not the
> same on all systems.  We're still looking for a more robust solution to
> this.

Do we do everything dwm does wrt. numLock? If not, we'll have to
document this for 0.1 at least.

-- Don