aeson-utils: aeson-0.9 compatibility package

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

aeson-utils: aeson-0.9 compatibility package

Adam Bergmark-2
Hi folks,

aeson-0.9 was released today. It changes the behavior of `decode` and `eitherDecode`: They now both allow atomic values on the top level. Previously the behavior was inconsistent, `encode 1 = "1"` but `decode "1" :: Maybe Int = Nothing`.

aeson-utils[1] has the functions `decodeV` and `eitherDecodeV` that work like aeson-0.9's `decode` and `eitherDecode` respectively, also with older aeson versions. If you want to stay backwards compatible without having varying semantics based on dependencies, check it out!


Regards,
Adam


_______________________________________________
Libraries mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries