arc stopped working

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

arc stopped working

Peter Trommler-3
Hi *,

I am getting the following error message from arc:

peter@montebre:/local/home/peter/ghc> arc diff
Usage Exception: Failed to load phutil library at location '/local/home/peter/ghc/.arc-linters/arcanist-external-json-linter'. This library is specified by the "load" setting in ".arcconfig". Check that the setting is correct and the library is located in the right place.

I looked at '/local/home/peter/ghc/.arc-linters/arcanist-external-json-linter' and it is an empty directory.
`arc upgrade` did not fix the issue.

What can I do to fix arc?

Thanks, Peter
_______________________________________________
ghc-devs mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs
Reply | Threaded
Open this post in threaded view
|

Re: arc stopped working

Eric Seidel-3
Have you tried `git submodule update --init`? I believe the arc linter
is a submodule.

On Fri, May 13, 2016, at 07:38, Peter Trommler wrote:

> Hi *,
>
> I am getting the following error message from arc:
>
> peter@montebre:/local/home/peter/ghc> arc diff
> Usage Exception: Failed to load phutil library at location
> '/local/home/peter/ghc/.arc-linters/arcanist-external-json-linter'. This
> library is specified by the "load" setting in ".arcconfig". Check that
> the setting is correct and the library is located in the right place.
>
> I looked at
> '/local/home/peter/ghc/.arc-linters/arcanist-external-json-linter' and it
> is an empty directory.
> `arc upgrade` did not fix the issue.
>
> What can I do to fix arc?
>
> Thanks, Peter
> _______________________________________________
> ghc-devs mailing list
> [hidden email]
> http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs
_______________________________________________
ghc-devs mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs
Reply | Threaded
Open this post in threaded view
|

Re: arc stopped working

Peter Trommler-3
Hi Eric,

Thanks a lot. That fixed arc for me.

Peter

> On 13.05.2016, at 16:50, Eric Seidel <[hidden email]> wrote:
>
> Have you tried `git submodule update --init`? I believe the arc linter
> is a submodule.
>
> On Fri, May 13, 2016, at 07:38, Peter Trommler wrote:
>> Hi *,
>>
>> I am getting the following error message from arc:
>>
>> peter@montebre:/local/home/peter/ghc> arc diff
>> Usage Exception: Failed to load phutil library at location
>> '/local/home/peter/ghc/.arc-linters/arcanist-external-json-linter'. This
>> library is specified by the "load" setting in ".arcconfig". Check that
>> the setting is correct and the library is located in the right place.
>>
>> I looked at
>> '/local/home/peter/ghc/.arc-linters/arcanist-external-json-linter' and it
>> is an empty directory.
>> `arc upgrade` did not fix the issue.
>>
>> What can I do to fix arc?
>>
>> Thanks, Peter
>> _______________________________________________
>> ghc-devs mailing list
>> [hidden email]
>> http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs
> _______________________________________________
> ghc-devs mailing list
> [hidden email]
> http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs

_______________________________________________
ghc-devs mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs