arm-apple-darwin10-cabal install woes

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

arm-apple-darwin10-cabal install woes

Schell Scivally
Hi all, I posted this earlier to the haskell-iphone list and heard it may
be better off here.

I'm having trouble installing primitive from hackage with
arm-apple-darwin10-cabal. It seems a funky error is happening that is not
getting written out or logged.

Here is the output from my attempted install from hackage after a `rm -rf
~/.cabal` and `arm-apple-darwin10-cabal update`: http://lpaste.net/97092.
Nothiing is listed in the log mentioned.

So I tried installing from the git repo and got the same error. Then I
tried to configure build and then install and the build phase spat out:

/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ranlib:
archive library: dist-arm/build/libHSprimitive-0.5.2.0.a will be fat and
ar(1) will not be able to operate on it

In-place registering primitive-0.5.2.0...

So it seems it's building but not linking? Maybe I shouldn't be developing
with cabal? What's the normal procedure here?


--
Schell Scivally
http://blog.efnx.com
http://github.com/schell
http://twitter.com/schellsan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/ghc-devs/attachments/20131216/0cadb900/attachment.html>