error: ghcide must be compiled with same GHC version as the project

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

error: ghcide must be compiled with same GHC version as the project

Dennis Raddle
I'm trying to use the Haskell extension with VS Code which, is my understanding, uses ghcide.

When I built ghcide, I had the resolver in the stack.yaml set to "nightly-2020-09-02". Associated with this is GHC 8.10.2.

When I first created my project I had the resolver set to something like lts-14.20. Associated with this is GHC something like 8.6.5.

Later I changed my project resolver to nightly-2020-09-02, same as ghcide. But I'm still getting this error.

Perhaps I haven't properly rebuilt my project using the new resolver?

Dennis

_______________________________________________
Haskell-Cafe mailing list
To (un)subscribe, modify options or view archives go to:
http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
Only members subscribed via the mailman list are allowed to post.