ghc-8.4.3 at Ubuntu

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

ghc-8.4.3 at Ubuntu

Andreas Röhler
While installing ghc-8.4.3-i386-deb8-linux.tar.xz at Debian8 went
smoothly, can't se how to install ghc-8.4.3 at Ubuntu resp. Xubuntu:


in dir ghc-8.4.3/

./configure
checking for gfind... no
checking for find... /usr/bin/find
checking for sort... /usr/bin/sort
checking for GHC Git commit id... given
51abb1c88b53e2989a2a8c2939ac4abc04bef194
checking for ghc... /usr/bin/ghc
checking version of ghc... 7.10.3
configure: error: GHC version 8.0 or later is required to compile GHC.

Did cabal update

and tried haskell-platform for ubuntu
https://www.haskell.org/platform/linux.html#linux-ubuntu

which seems broken

Tried Haskell-platform from source:

./platform.sh
***
*** Building hptool
***
cabal: unrecognised command: new-build (try --help)


Any help?

Cheers,
Andreas

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: ghc-8.4.3 at Ubuntu

Jeffrey Brown
You could use stack instead of cabal. The most recent nightly stack snapshots use GHC 8.4.3. Stack has a lot[1] of advantages. One of them is that you can use a bunch of different versions of GHC at the same time. Whereas Cabal keeps a global collection of Haskell software, Stack keeps a bunch of different local ones, while cleverly avoiding wasting memory like you might expect that to imply. If you have a project that needs old stuff that's incompatible with new stuff, you're SOL with Cabal but it's no problem in Stack.


On Mon, Jun 4, 2018 at 2:08 AM Andreas Röhler <[hidden email]> wrote:
While installing ghc-8.4.3-i386-deb8-linux.tar.xz at Debian8 went
smoothly, can't se how to install ghc-8.4.3 at Ubuntu resp. Xubuntu:


in dir ghc-8.4.3/

./configure
checking for gfind... no
checking for find... /usr/bin/find
checking for sort... /usr/bin/sort
checking for GHC Git commit id... given
51abb1c88b53e2989a2a8c2939ac4abc04bef194
checking for ghc... /usr/bin/ghc
checking version of ghc... 7.10.3
configure: error: GHC version 8.0 or later is required to compile GHC.

Did cabal update

and tried haskell-platform for ubuntu
https://www.haskell.org/platform/linux.html#linux-ubuntu

which seems broken

Tried Haskell-platform from source:

./platform.sh
***
*** Building hptool
***
cabal: unrecognised command: new-build (try --help)


Any help?

Cheers,
Andreas

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners


--
Jeff Brown | Jeffrey Benjamin Brown
Website   |   Facebook   |   LinkedIn(spammy, so I often miss messages here)   |   Github   

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: ghc-8.4.3 at Ubuntu

Ut Primum
In reply to this post by Andreas Röhler
Hi,
It seems as if you have also another version of GHC installed on your computer in another directory (usr/bin/ghc), and its version is 7.10.3, and it is considered the global version.
You could try to use a virtual environment for installing the version 8.4.3


(I've never tried so I am not sure it works)
Regards

Il lun 4 giu 2018, 09:08 Andreas Röhler <[hidden email]> ha scritto:
While installing ghc-8.4.3-i386-deb8-linux.tar.xz at Debian8 went
smoothly, can't se how to install ghc-8.4.3 at Ubuntu resp. Xubuntu:


in dir ghc-8.4.3/

./configure
checking for gfind... no
checking for find... /usr/bin/find
checking for sort... /usr/bin/sort
checking for GHC Git commit id... given
51abb1c88b53e2989a2a8c2939ac4abc04bef194
checking for ghc... /usr/bin/ghc
checking version of ghc... 7.10.3
configure: error: GHC version 8.0 or later is required to compile GHC.

Did cabal update

and tried haskell-platform for ubuntu
https://www.haskell.org/platform/linux.html#linux-ubuntu

which seems broken

Tried Haskell-platform from source:

./platform.sh
***
*** Building hptool
***
cabal: unrecognised command: new-build (try --help)


Any help?

Cheers,
Andreas

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: ghc-8.4.3 at Ubuntu

Andreas Röhler
Thanks all!

Will try hsenv.

Meanwhile recipe found here was succesful:

https://www.reddit.com/r/haskell/comments/5jsyr0/announce_ghc_802_release_candidate_2/

Did
sudo apt-add-repository ppa:hvr/ghc
sudo apt update
sudo apt install ghc-8.0.2 cabal-install-1.24

added /opt/ghc/bin to $PATH

Configure done so and make is running...

On 04.06.2018 09:30, Ut Primum wrote:

> Hi,
> It seems as if you have also another version of GHC installed on your
> computer in another directory (usr/bin/ghc), and its version is 7.10.3,
> and it is considered the global version.
> You could try to use a virtual environment for installing the version 8.4.3
>
> http://hackage.haskell.org/package/hsenv
>
> (I've never tried so I am not sure it works)
> Regards
>
> Il lun 4 giu 2018, 09:08 Andreas Röhler <[hidden email]
> <mailto:[hidden email]>> ha scritto:
>
>     While installing ghc-8.4.3-i386-deb8-linux.tar.xz at Debian8 went
>     smoothly, can't se how to install ghc-8.4.3 at Ubuntu resp. Xubuntu:
>
>
>     in dir ghc-8.4.3/
>
>     ./configure
>     checking for gfind... no
>     checking for find... /usr/bin/find
>     checking for sort... /usr/bin/sort
>     checking for GHC Git commit id... given
>     51abb1c88b53e2989a2a8c2939ac4abc04bef194
>     checking for ghc... /usr/bin/ghc
>     checking version of ghc... 7.10.3
>     configure: error: GHC version 8.0 or later is required to compile GHC.
>
>     Did cabal update
>
>     and tried haskell-platform for ubuntu
>     https://www.haskell.org/platform/linux.html#linux-ubuntu
>
>     which seems broken
>
>     Tried Haskell-platform from source:
>
>     ./platform.sh
>     ***
>     *** Building hptool
>     ***
>     cabal: unrecognised command: new-build (try --help)
>
>
>     Any help?
>
>     Cheers,
>     Andreas
>
>     _______________________________________________
>     Beginners mailing list
>     [hidden email] <mailto:[hidden email]>
>     http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
>
>
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners
>

_______________________________________________
Beginners mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/beginners