gtk2hs in Ubuntu Gutsy

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

gtk2hs in Ubuntu Gutsy

Chad Scherrer
I just installed the beta release for Ubuntu Gutsy, and I noticed that gtk2hs (provided by libghc6-gtk-dev) is still at version 0.9.10.5-1ubuntu1. Worse, it's apparently not installable; when I try I get this message:

libghc6-gtk-dev:
 Depends: ghc6 (<6.6+) but 6.6.1-2ubuntu2 is to be installed
 Depends: libghc6-cairo-dev but it is not going to be installed

Do any of you guys know why this wouldn't include a newer version? Probably just an oversight, I'm guessing.

--

Chad Scherrer

"Time flies like an arrow; fruit flies like a banana" -- Groucho Marx
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: gtk2hs in Ubuntu Gutsy

Stefan O'Rear
On Thu, Oct 04, 2007 at 09:31:56AM -0700, Chad Scherrer wrote:

> I just installed the beta release for Ubuntu Gutsy, and I noticed that
> gtk2hs (provided by libghc6-gtk-dev) is still at version 0.9.10.5-1ubuntu1.
> Worse, it's apparently not installable; when I try I get this message:
>
> libghc6-gtk-dev:
>  Depends: ghc6 (<6.6+) but 6.6.1-2ubuntu2 is to be installed
>  Depends: libghc6-cairo-dev but it is not going to be installed
>
> Do any of you guys know why this wouldn't include a newer version? Probably
> just an oversight, I'm guessing.
GHC does not have a stable binary interface, so binary libs for 6.6.0
will probably crash if linked by 6.6.1.

Stefan

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe

signature.asc (196 bytes) Download Attachment