libreadline dependency

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

libreadline dependency

J. Scott Thayer M.D.

Running Suse 9.3 64bit on Acer Ferrarri laptop. Haskell wants libreadline 4 while I have libreadline 5. Is there a definitive fix for this? The answers in archived messages were ‘sub-optimal’.

 


_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: libreadline dependency

Cale Gibbard
Could you not simply install both? At least in Debian, I have both
/lib/libreadline.so.4 (which is a symlink to 4.3)
/lib/libreadline.so.5 (which is a symlink to 5.1)

 - Cale

On 18/02/06, J. Scott Thayer, M.D. <[hidden email]> wrote:

>
>
>
> Running Suse 9.3 64bit on Acer Ferrarri laptop. Haskell wants libreadline 4
> while I have libreadline 5. Is there a definitive fix for this? The answers
> in archived messages were 'sub-optimal'.
>
>
> _______________________________________________
> Haskell-Cafe mailing list
> [hidden email]
> http://www.haskell.org/mailman/listinfo/haskell-cafe
>
>
>
_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: libreadline dependency

Jim Apple-2
In reply to this post by J. Scott Thayer M.D.
J. Scott Thayer, M.D. wrote:
> Haskell wants
> libreadline 4 while I have libreadline 5.

I'm not sure about SUSE, but Fedora has libreadline_compat packages.

HTH,
Jim

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe