"strange" error

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

"strange" error

Haskell - Glasgow-haskell-users mailing list
Hello,

I have compiled the latest veersion of ghc under OpenIndiana (Solaris) and now I am
trying to compile cabal. I downloaded the source code from

https://www.haskell.org/cabal/download.html

and I tried to compile. I used the bootstrap.sh script bit it failed:

Configuring cabal-install-2.0.0.1...
Setup: Encountered missing dependencies:
HTTP >=4000.1.5 && <4000.4,
async >=2.0 && <3,
cryptohash-sha256 ==0.11.*,
hackage-security >=0.5.2.2 && <0.6,
hashable >=1.0 && <2,
tar >=0.5.0.3 && <0.6


Error during cabal-install bootstrap:
Configuring the cabal-install package failed.

The script downloaded all these packages so I tried to see why they fail:

$ cd HTTP-4000.3.7
$ ls
CHANGES     HTTP.cabal  Network     test
dist        LICENSE     Setup.lhs
$ runhaskell Setup configure
Configuring HTTP-4000.3.7...
Setup: Encountered missing dependencies:
base >=4.3.0.0 && <4.11

Of course this package is already installed and this means that
for some reason it cannot find it. It is quite possible that I am doing
something stupid but I would like to know how can I proceed?

Thanks in advance for your help/assistance.
A.S.


--
Apostolos Syropoulos
Xanthi, Greece


_______________________________________________
Glasgow-haskell-users mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/glasgow-haskell-users