rts package in an invalid state

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

rts package in an invalid state

aditya siram-2
Hi all,
I recently compiled and installed ghc 6.10.2 on a clean system. But a
'ghc-pkg check' shows an error with the rts package [1]. A google
search advised me to install libffi5. I did this but keep getting the
same error. Any ideas?

Thanks ...
deech

[1] http://hpaste.org/fastcgi/hpaste.fcgi/view?id=3630#a3630
Reply | Threaded
Open this post in threaded view
|

rts package in an invalid state

Jason Dusek
  Oh, look at this:

    http://www.nabble.com/ghc-pkg-check-problem-in-6.10.2-td22846037.html

  Seems to have come up not too long ago.

--
Jason Dusek
Reply | Threaded
Open this post in threaded view
|

rts package in an invalid state

aditya siram-2
Yes, this was it! Thanks for much!
-deech

On Fri, Apr 10, 2009 at 5:40 PM, Jason Dusek <[hidden email]> wrote:
> ?Oh, look at this:
>
> ? ?http://www.nabble.com/ghc-pkg-check-problem-in-6.10.2-td22846037.html
>
> ?Seems to have come up not too long ago.
>
> --
> Jason Dusek
>
Reply | Threaded
Open this post in threaded view
|

rts package in an invalid state

Raja Koduru
Hi,
Just did ghc-pkg check on my system just out of curiosity.
Even here I am getting the rts package errors.

But I followed the instructions given at the above url to rectify it.

To my surprise there is one more such error. It is related to haddock-2.4.2.

Pasting here the 'ghc-pkg check's dump
----------------------------------------------------------------------------------------------------------------------------------------------------
C:\Program Files\Haskell>ghc-pkg check
There are problems in package haddock-2.4.2:
  import-dirs: c:/builds/slave/x86-win-stable/build/ghc-6.10.2\haddock-2.4.2
doesn't exist or isn't
a directory
  library-dirs:
c:/builds/slave/x86-win-stable/build/ghc-6.10.2\haddock-2.4.2 doesn't
exist or isn't
 a directory
  file Distribution\Haddock.hi is missing
  file Haddock\DocName.hi is missing
  file Haddock\Types.hi is missing
  file Haddock\InterfaceFile.hi is missing
  file Haddock\Exception.hi is missing
  file Haddock\Utils.hi is missing
  file Haddock\GHC\Utils.hi is missing
  cannot find libHShaddock-2.4.2.a on library path

The following packages are broken, either because they have a problem
listed above, or because they depend on a broken package.
haddock-2.4.2
-----------------------------------------------------------------------------------------------------------------------------------------------------


I am using 6.10.2 on windows XP.

Any suggestions on how to rectify this?

-raja
Reply | Threaded
Open this post in threaded view
|

rts package in an invalid state

aditya siram-2
I had this problem with the HTTP package. I followed the following steps:
1. Unregister the offending package with 'ghc-pkg unregister <packagename>'
2. Download the package from Hackage
3. Manually compile and install the package
4. Check that the package is in the list with 'ghc-pkg list'
5. Rerun 'ghc-pkg check'

hth,
deech

On Fri, Apr 10, 2009 at 8:55 PM, Raja Koduru <[hidden email]> wrote:

> Hi,
> Just did ghc-pkg check on my system just out of curiosity.
> Even here I am getting the rts package errors.
>
> But I followed the instructions given at the above url to rectify it.
>
> To my surprise there is one more such error. It is related to haddock-2.4.2.
>
> Pasting here the 'ghc-pkg check's dump
> ----------------------------------------------------------------------------------------------------------------------------------------------------
> C:\Program Files\Haskell>ghc-pkg check
> There are problems in package haddock-2.4.2:
> ?import-dirs: c:/builds/slave/x86-win-stable/build/ghc-6.10.2\haddock-2.4.2
> doesn't exist or isn't
> a directory
> ?library-dirs:
> c:/builds/slave/x86-win-stable/build/ghc-6.10.2\haddock-2.4.2 doesn't
> exist or isn't
> ?a directory
> ?file Distribution\Haddock.hi is missing
> ?file Haddock\DocName.hi is missing
> ?file Haddock\Types.hi is missing
> ?file Haddock\InterfaceFile.hi is missing
> ?file Haddock\Exception.hi is missing
> ?file Haddock\Utils.hi is missing
> ?file Haddock\GHC\Utils.hi is missing
> ?cannot find libHShaddock-2.4.2.a on library path
>
> The following packages are broken, either because they have a problem
> listed above, or because they depend on a broken package.
> haddock-2.4.2
> -----------------------------------------------------------------------------------------------------------------------------------------------------
>
>
> I am using 6.10.2 on windows XP.
>
> Any suggestions on how to rectify this?
>
> -raja
>
Reply | Threaded
Open this post in threaded view
|

rts package in an invalid state

Raja Koduru
Thank you. It worked.

Instead of downloading the package from hackage
I used "cabal install <package>".

Now I am not getting that error.

I believe that using cabal and manual compilation are equivalent when
it comes to package installation.
Correct me If am wrong.

-raja