template-haskell error

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

template-haskell error

Belka
Hello!

Please, help!
I'm a newby to Haskell. While trying to compile HAppS package, I got an error. Should I report it anywhere? I'm going to try to fix it, but how do I localize it? If anybody has apropriate experience, please, share it..

--LOG-----------------------------------------
ghc-6.10.1

[~] > darcs get --partial http://happs.org/HAppS/HAppS-Data
...
[~] > cd HApps-Data
[HApps-Data] > sudo runghc Setup configure --user
Configuring HAppS-Data-0.9.3..

[HApps-Data] > sudo runghc Setup build
...
[ 7 of 19] Compiling HAppS.Data.HListBase ( src/HAppS/Data/HListBase.hs, dist/build/HAppS/Data/HListBase.o )
Loading package ghc-prim ... linking ... done.
Loading package integer ... linking ... done.
Loading package base ... linking ... done.
Loading package syb ... linking ... done.
Loading package array-0.2.0.0 ... linking ... done.
Loading package bytestring-0.9.1.4 ... linking ... done.
Loading package containers-0.2.0.0 ... linking ... done.
Loading package packedstring-0.1.0.1 ... linking ... done.
Loading package pretty-1.0.1.0 ... linking ... done.
ghc: /usr/lib/ghc-6.10.1/template-haskell-2.3.0.0/HStemplate-haskell-2.3.0.0.o: unknown symbol `prettyzm1zi0zi1zi0_TextziPrettyPrintziHughesPJ_lvl77_closure'
Loading package template-haskell ... linking ... ghc: unable to load package `template-haskell'
Reply | Threaded
Open this post in threaded view
|

SOLVED

Belka
Well the problem is solved.

After some poking the the problematic module (adding/removing words) -> found myself on the bottom of helplessness -> when a kind person suggested reinstalling package "pretty". This advice showed immidiate progress.

So I reinstalled

* pretty
* template-haskell
* syb-with-classes

, and problem is solved!