xmonad --replace works, but not xmonad.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

xmonad --replace works, but not xmonad.

e.a.gebhart

I'm getting some really strange behavior after an upgrade on Arch.
Of course.

I finally got everything compiling again, and if I use xfce first
and then do a replace it works like expected.

If I run xmonad with startx or sddm, it almost works.
I can quit Xmonad, but that is all. I do a S-Mod-Q it will exit, but I can't get anything else to work.
If I mess around to much that doesn't even work.

I reduced my xinitrc to "exec xmonad".

I even tried without my xmonad.hs but no change.  I couldn't even bring
up an xterm.

One thing that is suspicious Is that I can't get xinit to just start an
xterm so that I can run xmonad manually to see what happens.

I get connection errors for tty0.  But :0 is the one I think I'm
connecting to.  I tried vt :0 and :1. The log by default is Xorg.0.log
and there is nothing going wrong there.

At this point I'm looking for ideas.
Using --replace from an xfce login is messy with it's sessions and so forth.

I've been working on this for days now.

any ideas are appreciated.

Thanks,

Eric
_______________________________________________
xmonad mailing list
[hidden email]
http://mail.haskell.org/cgi-bin/mailman/listinfo/xmonad