zlib 0.5.3.2 broken?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

zlib 0.5.3.2 broken?

Michael Snoyman
Hi all,

I've received a number of reports of a broken zlib 0.5.3.2 (and
experienced it myself). Is this a generally known issue?

As a temporary workaround, I've released a new version of
zlib-bindings that has an upper bound on zlib to avoid 0.5.3.2 (and
later). Once a new patched version is released, I'll release an
updated version of zlib-bindings to remove that overly restrictive
upper bound.

Michael

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: zlib 0.5.3.2 broken?

Erik Hesselink
I recently ran into this as well. I found this stack overflow question
[1], where Daniel Fischer notes that a proper solution has been found,
and it shouldn't be long until it reaches hackage. That was one and a
half weeks ago.

Erik

[1] http://stackoverflow.com/questions/8961413/zlib-build-error-with-ghc

On Thu, Feb 2, 2012 at 06:59, Michael Snoyman <[hidden email]> wrote:

> Hi all,
>
> I've received a number of reports of a broken zlib 0.5.3.2 (and
> experienced it myself). Is this a generally known issue?
>
> As a temporary workaround, I've released a new version of
> zlib-bindings that has an upper bound on zlib to avoid 0.5.3.2 (and
> later). Once a new patched version is released, I'll release an
> updated version of zlib-bindings to remove that overly restrictive
> upper bound.
>
> Michael
>
> _______________________________________________
> Haskell-Cafe mailing list
> [hidden email]
> http://www.haskell.org/mailman/listinfo/haskell-cafe

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: zlib 0.5.3.2 broken?

JP Moresmau
In reply to this post by Michael Snoyman
I had an issue as well and the explanation is on StackOverflow, so I
suppose it is a known issue:
http://stackoverflow.com/questions/8961413/zlib-build-error-with-ghc

Putting a double # in front of the offending preprocessor directives
fixed it for me.

JP

On Thu, Feb 2, 2012 at 6:59 AM, Michael Snoyman <[hidden email]> wrote:

> Hi all,
>
> I've received a number of reports of a broken zlib 0.5.3.2 (and
> experienced it myself). Is this a generally known issue?
>
> As a temporary workaround, I've released a new version of
> zlib-bindings that has an upper bound on zlib to avoid 0.5.3.2 (and
> later). Once a new patched version is released, I'll release an
> updated version of zlib-bindings to remove that overly restrictive
> upper bound.
>
> Michael
>
> _______________________________________________
> Haskell-Cafe mailing list
> [hidden email]
> http://www.haskell.org/mailman/listinfo/haskell-cafe



--
JP Moresmau
http://jpmoresmau.blogspot.com/

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: zlib 0.5.3.2 broken?

Mark Wright-2
In reply to this post by Michael Snoyman
On Thu, 2 Feb 2012 07:59:08 +0200, Michael Snoyman <[hidden email]> wrote:

> Hi all,
>
> I've received a number of reports of a broken zlib 0.5.3.2 (and
> experienced it myself). Is this a generally known issue?
>
> As a temporary workaround, I've released a new version of
> zlib-bindings that has an upper bound on zlib to avoid 0.5.3.2 (and
> later). Once a new patched version is released, I'll release an
> updated version of zlib-bindings to remove that overly restrictive
> upper bound.
>
> Michael

Hi Michael,

zlib 0.5.3.2 builds fine, with ghc 7.0.4 Cabal-1.10.2.0 it just needs
some help to find the header file containing the macros generated by
cabal.  To avoid the error:

Stream.hsc:86:21: error: missing binary operator before token "("

in the Gentoo Haskell overlay I pass this extra option to the
runghc ./Setup.hs configure:

--hsc2hs-options=--include=${S}/dist/build/autogen/cabal_macros.h

where ${S} is the source code directory.

With ghc 7.2.2 and 7.4.1-rc2 it compiles fine with or without
this configure option.

Mark

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe
Reply | Threaded
Open this post in threaded view
|

Re: zlib 0.5.3.2 broken?

Roel van Dijk-3
bzlib-0.5.0.2 suffers from the exact same problem. I send a bug report
to the author a few days ago, but I can imagine he's very busy. It
might help if we can send patches that fix the compile error.

_______________________________________________
Haskell-Cafe mailing list
[hidden email]
http://www.haskell.org/mailman/listinfo/haskell-cafe